Flagged Out-of-Date Comment: libm2k-git

MarsSeed flagged libm2k-git out-of-date on 2023-11-30 (UTC) for the following reason:

Broken: needs depends=libiio. Also please kindly cut the 'v' prefix from pkgver.