Package Base Details: libopenmpt

Git Clone URL: https://aur.archlinux.org/libopenmpt.git (read-only, click to copy)
Keywords: it mod tracker xm
Submitter: carstene1ns
Maintainer: carstene1ns
Last Packager: carstene1ns
Votes: 7
Popularity: 0.116614
First Submitted: 2016-01-07 18:41
Last Updated: 2020-07-23 14:36

Packages (2)

Latest Comments

1 2 Next › Last »

carstene1ns commented on 2020-07-25 16:13

@milk: `libopenmpt-modplug` has been part of this package and is now separated, you need to update it as well.

If nothing else works, remove it manually (this ignores dependencies):
$ pacman -Rdd libopenmpt-modplug

milk commented on 2020-07-24 13:52

Waking up to a breaking system update.

...
==> Leaving fakeroot environment.
==> Finished making: libopenmpt 0.5.0-1 (Fri 24 Jul 2020 13:27:53 BST)
==> Cleaning up...
 -> libopenmpt>=0.5.0 not satisfied, flushing install queue
loading packages...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing libopenmpt (0.5.0-1) breaks dependency 'libopenmpt=0.4.11' required by libopenmpt-modplug
yay -Syu --answeredit n --answerupgrade n --answerclean n --answerdiff n     2407.63s user 219.38s system 73% cpu 59:12.55 total

I'm not sure how to quickly diagnose and I've other things, so just raising a comment here for now.

carstene1ns commented on 2020-07-23 15:31

@katt: I have added a separate libopenmpt-modplug package now.

katt commented on 2020-04-19 17:10

Looks like libopenmpt-modplug is being deprecated as being a part of the regular libopenmpt package. https://lib.openmpt.org/libopenmpt/2020/04/13/release-libopenmpt-modplug-0.8.8.5-openmpt1/

sxiii commented on 2020-04-16 13:42

Needs to be updated to 0.4.12

shoober420 commented on 2019-02-05 18:34

The PKGBUILD should link to version “0.4.2”

Also, since this package hasn’t been updated in a long time, I’ll maintain it if desired.

rfs commented on 2018-12-02 17:52

This package is a great quick fix for some music players that use modplug by default and can't handle certain ImpulseTracker files that well.

jseb commented on 2018-09-04 09:53

For 3.11+ (released 2018-07-28), just change this to the PKGBUILD:

_pkgver=0.3.11+release sha256sums=('441b3f1127e955678c6a37c524c3c2a875c37f5823e41fcb2c5c59b6d715d8ce')

shoober420 commented on 2018-07-31 17:54

3.11 has recently been released

carstene1ns commented on 2017-10-08 19:03

Kakashi-sensei> Error message "openmpt123 and openmpt123-minimal are in conflict". Bad packaging.

Just because your AUR helper does not properly understand split packages, this is not a bad package.