Package Base Details: lightly-git

Git Clone URL: https://aur.archlinux.org/lightly-git.git (read-only, click to copy)
Submitter: Scrumplex
Maintainer: D3SOX (xiota)
Last Packager: xiota
Votes: 9
Popularity: 0.010488
First Submitted: 2020-08-03 11:07 (UTC)
Last Updated: 2024-04-02 23:46 (UTC)

Latest Comments

1 2 3 Next › Last »

LPW00 commented on 2024-04-29 21:19 (UTC)

oh crap I thought I read the PKGBUILD, guess I didn't. sorry

xiota commented on 2024-04-29 18:16 (UTC)

@LPW00 The PKGBUILD is working correctly. If you want to build only one of the packages, you can change the variables at the beginning of the file. As far as I know, no AUR helper can do it for you.

LPW00 commented on 2024-04-29 17:57 (UTC) (edited on 2024-04-29 18:01 (UTC) by LPW00)

Lightly requires kf5 stuff as make dependencies even if you build it for plasma 6. As it is, this fails with


==> Making package: lightly-git 0.4.1.r73.g00ca234-4 (Mon Apr 29 19:52:11 2024)
==> Checking runtime dependencies...
==> Missing dependencies:
  -> frameworkintegration5
  -> kcmutils5
  -> kconfig5
  -> kcoreaddons5
  -> kdecoration5
  -> kguiaddons5
  -> ki18n5
  -> kiconthemes5
  -> kwayland5
  -> kwindowsystem5
  -> qt5-declarative
==> Checking buildtime dependencies...
==> ERROR: Could not resolve all dependencies.
error: failed to build 'lightly-git-0.4.1.r73.g00ca234-4 (lightly-kf6-git)':

xiota commented on 2024-04-28 14:29 (UTC)

The -qt6 package has been deleted. If anyone has an opinion about changing from -kf# to -qt#, briefly explain reasons and I'll consider... Otherwise, will leave as is because it seems to be working (at least no complaints it isn't).

xiota commented on 2024-04-03 12:09 (UTC)

While kf5/6 in the package names is somewhat unusual, naming with qt5/6 might be considered inaccurate because kf5/6 are needed to build and use these packages.

I've commented at the -qt6-git package to notify the maintainer and interested users of changes to this package.

alba4k commented on 2024-04-03 09:30 (UTC) (edited on 2024-04-03 09:31 (UTC) by alba4k)

Well done! Send a deletion request for -qt6 maybe

and then maybe you can ask to rename those to -qt5 and -qt6, which would at least be more intuitive

Maybe talk about it with the maintainer first, as requests sent by maintainers are reviewed with higher priority

xiota commented on 2024-04-02 05:28 (UTC) (edited on 2024-04-02 05:55 (UTC) by xiota)

Converted to a split package. Using -kf# because -qt6 is taken. Did not combine everything to keep KF5 and KF6 depends separate. Let me know if any problems.

alba4k commented on 2024-04-01 22:17 (UTC)

It could even just be a -bin version providing the old theme, already built.

But really, a qt5 package to be installed alongside the qt6 one would be great (now that lightly-git and lightly-qt6-git are no longer the way to go). This should also be considered by upstream, tho.