Package Base Details: linux-amd

Git Clone URL: https://aur.archlinux.org/linux-amd.git (read-only, click to copy)
Submitter: eggz
Maintainer: eggz (NhaMeh)
Last Packager: eggz
Votes: 13
Popularity: 1.21
First Submitted: 2019-11-10 15:20
Last Updated: 2021-12-01 09:30

Pinned Comments

eggz commented on 2020-10-26 18:15

GCC11.1 is mainlined in arch, so this means znver3 support can kick off on this kernel. The graysky compile patches have been updated too.

This kernel now natively supports the znver3 arch, but this kernel will most likely keep working on all AMD ryzen hardware. It's better to be able to address certain small perks or issues per architecture now and in the future.

If you use znver2 based hardware, please use linux-amd-znver2
If you use raven based hardware, please use linux-amd-raven

eggz commented on 2019-11-10 15:23

Tired of compiling? Use this binary repo instead! Add this at the end of /etc/pacman.conf :

[linuxkernels]
Server = http://nhameh.ovh/$repo/$arch
SigLevel = Optional TrustAll

Latest Comments

1 2 3 4 5 6 ... Next › Last »

astor commented on 2021-11-02 18:18

@eggz solved editing PKGBUILD as you said. I can confirm that it is working. Thank you very much.

eggz commented on 2021-11-02 17:53

@Astor

It was an easy fix. Only one file needs modifications: https://github.com/egnappahz/rtl8821ce/blob/8d1fa1bdc38c31c4ae69d6dd48c0f8f70ed57f71/core/rtw_br_ext.c ( https://github.com/egnappahz/rtl8821ce/commit/8d1fa1bdc38c31c4ae69d6dd48c0f8f70ed57f71 )

To get it easily, You can replace the gitsource in the PKGBUILD of rtl8821ce-dkms-git with my forked version;

source=("git+https://github.com/egnappahz/rtl8821ce.git")

and then run a good old makepkg -fi, compilation should work then. Atleast it did for me. I don't have the hardware tho so I cant test it out myself.

eggz commented on 2021-11-02 17:31

Hi Astor, Thanks for letting me know.

IPX is not supported by the linux kernel since v5.15-rc1.

The module will have to update accordingly: all NET_INET_IPX_H references in the C code will need to be handled by the dev.

As of now rtl8821ce (https://github.com/tomaspinho/rtl8821ce/actions) is deprecated untill they take action.

Ill take a look at the C code if an easy fix is possible but I won't make any promises there.

astor commented on 2021-11-02 17:05

I'm having issues with rtl8821ce module with this kernel: Warning, `dkms install --no-depmod -m rtl8821ce -v 1.0.5.r128.gf93db73 -k 5.15.0-AMD' returned 10

Kernel issue or module?

eggz commented on 2021-10-21 16:02

You can find the intel optimised version here:

https://archlinux.org/packages/core/x86_64/linux/

NhaMeh commented on 2021-10-21 14:13

Could you make an Intel optimised version? Thanks!

eggz commented on 2021-10-18 16:08

No prob, I just want to keep the PKGBUILD as simple as possible. If people want advanced stuff its best they make the modifications on their own.

Always remember other people are using it as well. If people love to compile a certain way, it would be dangerous to override it with scripts and the likes.

avzb_arch commented on 2021-10-18 14:50

Sorry for my bad english, I didn't mean that.

I just want to help after reading the PKGBUILD You shared.

The newbie about maintain arch package is just me, so basically I am just ask permit to You Can I help or not.

But no problem, thanks for maintaining this, really useful.

eggz commented on 2021-10-18 13:10

No thanks, I dont like telling people what to do. And if people dont know how makepkg.conf works then compiling is not for them.

ps: Do you really think I'm not capable of scripting that? Wow, thx man...

avzb_arch commented on 2021-10-18 12:33

Hi @eggz, I'd like to add some script to automatically use CPU Cores - 1 in the PKGBUILD to the script, could You allow me?