Package Base Details: linux-macbook

Git Clone URL: https://aur.archlinux.org/linux-macbook.git (read-only)
Submitter: m3thodic
Maintainer: annguyenfoss
Last Packager: annguyenfoss
Votes: 35
Popularity: 1.945381
First Submitted: 2016-07-05 23:22
Last Updated: 2019-05-29 03:29

Pinned Comments

annguyenfoss commented on 2019-05-29 03:33

Built and tested 5.1.5.arch1-1. Released. However, there are differences between this build's config and official kernel build's. I'll review and address those differences in next builds.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

portabello commented on 2019-04-28 21:31

I have installed the latest version 5.0.9 from the binary repo but neither the lighting controls or the suspend work. I have an early 2015 macbook pro with 13" retina display. My computer won't resume from suspend mode and I am forced to hold the power button down and restart. This happens regardless of whether macbook-wakeup.service is enabled. Additionally closing the lid only enters suspend mode when I am using a wm. When in tty mode I need to run syatemctl suspend. Brightness controls don't work either. The behavior seems to be identical to using the normal arch kernel.

architekt commented on 2019-01-05 04:54

I can't seem to find any information which devices are supported with this? I'm running a Macbook Pro 10,x (15" Retina Early 2013), would this be compatible?

FiniteParadox commented on 2018-12-28 12:03

Can provides=("linux=${pkgver}") and provides=("linux-headers=${pkgver}") fields be added in PKGBUILD (sections _package() and _package-headers() respectively) so that packages that depend on linux are satisfied by linux-macbook?

kflak commented on 2018-11-30 19:09

Thanks for this one! Unfortunately I am still not getting good enough audio performance from this, and have to use the rt-lts kernel, as this is the only kernel I have found that 1) gives rock solid audio performance and 2) wakes up after lid close-induced suspend... However, the package seems not to be maintained much, so I'd be very interested in a macbook-centric version of the realtime patch. Any hope for such a thing? Alternatively, any pointers as to how I could compile such a beast myself?

LawnGnome commented on 2018-11-27 21:11

@m3thodic Thanks! The new package installs fine for me. I didn't get it via pacman -Syu, though: it seems like the repo metadata still points to -1.

m3thodic commented on 2018-11-27 01:15

@LawnGnome Should be all set, thanks again!

m3thodic commented on 2018-11-27 00:42

@LawnGnome Hmm, yeah was afraid I had overlooked something -- I was coming from the 4.18.16 package to 4.19.4 and ran into a little snag. Thanks for the heads-up I'll build a new package straight from the AUR source to be safe and I'll push it up shortly.

LawnGnome commented on 2018-11-26 20:35

I'm getting a file conflict with the 4.19.4.arch1-1 binary package:

error: failed to commit transaction (conflicting files)
linux-macbook: /usr/lib/systemd/system exists in filesystem
Errors occurred, no packages were upgraded.

Building from source did not result in the same conflict, interestingly.

espenaf commented on 2018-10-23 17:02

Works now, tnx.

m3thodic commented on 2018-10-17 20:47

@espenaf I just updated to 4.18.14 -- can you please try now? Thanks!