Package Base Details: linux-pf-lts

Git Clone URL: https://aur.archlinux.org/linux-pf-lts.git (read-only)
Submitter: nous
Maintainer: nous
Last Packager: nous
Votes: 4
Popularity: 0.002535
First Submitted: 2015-01-16 18:45
Last Updated: 2018-11-27 13:33

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

Jeffrey4l commented on 2015-09-10 11:31

Why the config doesn't have `CONFIG_CGROUP_CPUACCT=y` configuration?

nous commented on 2015-05-31 20:52

I'm still getting a compile error, even with the linux-lts gcc5 patch:
LD [M] drivers/staging/rtl8187se/r8187se.o
drivers/staging/rtl8187se/r8180_wx.o: In function `ieee80211_increment_scans':
r8180_wx.c:(.text+0x18a0): multiple definition of `ieee80211_increment_scans'
drivers/staging/rtl8187se/r8180_core.o:r8180_core.c:(.text+0x3f70): first defined here

Anonymous comment on 2015-05-31 14:55

please add this patch
https://projects.archlinux.org/svntogit/packages.git/tree/trunk/gcc5_buildfixes.diff?h=packages/linux-lts

nous commented on 2015-05-31 08:14

The repo is updated to 3.14.43. However, to build closed modules such as nvidia, catalyst or virtualbox, people with gcc!=4.9 would need to export IGNORE_CC_MISMATCH=1 before running dkms or mkinitcpio.

nous commented on 2015-05-30 09:08

I confirmed it.
LD [M] drivers/staging/lustre/lustre/obdclass/obdclass.o
scripts/Makefile.build:455: recipe for target 'drivers/staging' failed
make[1]: *** [drivers/staging] Error 2
Makefile:843: recipe for target 'drivers' failed
make: *** [drivers] Error 2


It also fails at patchlevel 3.14.43, which means that the maintainer of obdclass hasn't yet updated his/her code for gcc5. For the time being I'll downgrade my build box to 4.9 and populate [pfkernel] with 3.14.43...

Anonymous comment on 2015-05-29 12:11

Failed to build with gcc 5.1.0

post-factum commented on 2015-02-25 20:43

Voting about GCC optimizations patch: https://plus.google.com/105187899411277204747/posts/HNaTndmBCyr

pavbaranov commented on 2015-02-25 09:15

As it's explain there: https://aur.archlinux.org/packages/linux-pf/ we cannot build proper pf-kernel for Intel processor with graysky's GCC optimization patch (included in pf-patch) with GCC 4.9.x which is in Arch repository now.

pavbaranov commented on 2015-02-25 09:10

As it's explain there: https://aur.archlinux.org/packages/linux-pf/ we cannot build proper pf-kernel with graysky's GCC optimization patch (included in pf-patch) with GCC 4.9.x which is in Arch repository now.

post-factum commented on 2015-02-24 22:42

Resync against stable tree:

https://pf.natalenko.name/forum/index.php?topic=289.0