Package Base Details: lua-path

Git Clone URL: https://aur.archlinux.org/lua-path.git (read-only, click to copy)
Submitter: alerque
Maintainer: alerque
Last Packager: alerque
Votes: 1
Popularity: 0.000002
First Submitted: 2019-06-27 08:34
Last Updated: 2021-01-07 13:34

Latest Comments

alerque commented on 2021-01-07 13:34

@alex.shpilkin Thanks for the patch, but ... um ... I updated this module for the Lua 5.4 release back in August! It looks like I built it and pushed it out to my Arch user package repository but forgot to push it to the AUR! Ooops, sorry about that. By the way you can make PR's against any of my packages here.

alex.shpilkin commented on 2020-12-25 17:59

Confirmed the issue is because of the 5.3 to 5.4 upgrade. Here is the fix (if you got an email for my earlier—now deleted—comment, please ignore it, I messed up):

diff --git a/PKGBUILD b/PKGBUILD
index 66a70d6..9e807ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@

 _rockname=path
 pkgbase="lua-$_rockname"
-pkgname=("lua-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
+pkgname=("lua-$_rockname" "lua53-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
 pkgver=0.3.1
 _rockrel=1
-pkgrel=3
+pkgrel=4
 pkgdesc='File system path manipulation library'
 arch=('i686' 'x86_64')
 url="https://github.com/moteus/$pkgbase"
 license=('MIT')
-makedepends=('lua' 'lua52' 'lua51' 'luarocks')
+makedepends=('lua' 'lua53' 'lua52' 'lua51' 'luarocks')
 source=("$_rockname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
 sha256sums=('f7419d9012cb5005a9adbc6e567fee44832a42a73532451336de066ff2ebcce5')

@@ -22,6 +22,11 @@ _package_helper() {

 package_lua-path() {
   depends+=('lua')
+  _package_helper 5.4
+}
+
+package_lua53-path() {
+  depends+=('lua53')
   _package_helper 5.3
 }

alex.shpilkin commented on 2020-12-25 17:01

On trying to build this package in a clean chroot, this happens:

==> Starting package_lua-path()...
Warning: Lua 5.3 interpreter not found at /usr

Modules may not install with the correct configurations. You may want to configure the path prefix to your build of Lua 5.3 using

   luarocks config --local lua_dir <your-lua-prefix>

/usr/bin/lua5.4: /usr/share/lua/5.4/luarocks/cmd.lua:166: bad error, expected string, got: nil
stack traceback:
    [C]: in function 'assert'
    /usr/share/lua/5.4/luarocks/cmd.lua:166: in upvalue 'die'
    /usr/share/lua/5.4/luarocks/cmd.lua:668: in function 'luarocks.cmd.run_command'
    /usr/bin/luarocks:38: in main chunk
    [C]: in ?

The lua package in the repos now points to 5.3 instead of 5.4, and this package does not have lua53 in makedepends. I suspect this is the reason for the error.