Package Base Details: lua-posix-git

Git Clone URL: https://aur.archlinux.org/lua-posix-git.git (read-only, click to copy)
Submitter: xyproto
Maintainer: berquist (alerque)
Last Packager: alerque
Votes: 5
Popularity: 0.000000
First Submitted: 2015-02-27 13:07 (UTC)
Last Updated: 2022-03-24 18:17 (UTC)

Latest Comments

matse commented on 2020-08-06 08:11 (UTC)

"git describe" refers to a pretty outdated tag (?) that's why this package always build v33.4.0. "Manually adjusting" this to v35.0 and setting _package_helper 5.4 leads to a lua 5.4 compatible version :)

berquist commented on 2020-03-01 03:35 (UTC)

@caleb Done!

alerque commented on 2020-02-18 05:33 (UTC)

Hey @berquist would you be interested in help setting this up as a basepackage that builds Lua 5.1 and 5.2 subpackages as well, much like we just finished arranging for lua-posix? If so please add me as a co-maintainer and I'll set it up.

cafehaine commented on 2018-10-25 12:42 (UTC)

this requires std.normalize, which I provide in the package lua-std-normalize

berquist commented on 2017-02-05 05:35 (UTC)

Yes. It looks like the PKGBUILD needs to nuke this line in the now-absent boostrap.conf: help2man 1.29 http://www.gnu.org/s/help2man as a build requirement. Removing everything to do with bootstrap.conf (and going on the GitHub page) reveals that they no longer use autoconf but luke, whatever that is; I can try and fix it, but would gladly accept help if someone already knows the solution.

Dobbie03 commented on 2017-01-25 17:35 (UTC)

Any one else getting this error : ==> Validating source files with md5sums... lua-posix ... Skipped ==> Extracting sources... -> Creating working copy of luaposix git repo... Cloning into 'lua-posix'... done. ==> Starting prepare()... sed: can't read bootstrap.conf: No such file or directory ==> ERROR: A failure occurred in prepare(). Aborting... ==> ERROR: Makepkg was unable to build lua-posix-git. ==> Restart building lua-posix-git ? [y/N] ==> -------------------------------------- ==>

haawda commented on 2015-02-27 14:28 (UTC)

Re-adopted after rename

xyproto commented on 2015-02-27 13:08 (UTC)

haawda, renamed. Please adopt.

haawda commented on 2015-02-26 15:12 (UTC)

Rebuild the package. It pulls from git. Maybe I should let a TU rename it to lua-posix-git to reflect this.

woyzeck1837 commented on 2015-02-26 08:50 (UTC)

Dear Maintainer, could you please update this package to the current upstream version? We are using lmod (https://www.tacc.utexas.edu/research-development/tacc-projects/lmod) and since the last update of lua-posix in November 2014 we have problems with the use of setenv.posix in lmod because of a bug in lua-posix (fixed December 16, see https://github.com/luaposix/luaposix/commit/6777663207df9b8e682e2599552412414cbe1672). Thank you!

haawda commented on 2014-11-25 19:35 (UTC)

Because it pulls from git.

uffe commented on 2014-11-24 12:49 (UTC)

Why does this package not have any checksum ?