Package Base Details: mendeleydesktop

Git Clone URL: https://aur.archlinux.org/mendeleydesktop.git (read-only, click to copy)
Keywords: elsevier mendeley
Submitter: lpjhjdh
Maintainer: ali.molaei
Last Packager: ali.molaei
Votes: 302
Popularity: 2.88
First Submitted: 2009-06-10 18:28
Last Updated: 2021-02-08 08:39

Pinned Comments

akstrfn commented on 2018-10-02 15:21

To avoid crashs when opening PDF's, and hangout on exit install mendeleydesktop-bundled which packages Qt provided by the upstream.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

David01 commented on 2019-10-15 12:42

@akstrfn I have added export LD_LIBRARY_PATH=/opt/mendeleydesktop/lib/qt to ~/.bashrc and sourced it. No successful results:

[david@david-pc ~]$ mendeleydesktop 
qt5ct: using qt5ct plugin
QFSFileEngine::open: No file name specified
Failed to run mendeley:// link handler installer "/opt/mendeleydesktop/lib/mendeleydesktop/libexec/install-mendeley-link-handler.sh"
/opt/mendeleydesktop/lib/mendeleydesktop/libexec/QtWebEngineProcess --type=zygote --webengine-schemes=qrc:sLV --lang=en-US: symbol lookup error: /opt/mendeleydesktop/lib/mendeleydesktop/libexec/QtWebEngineProcess --type=zygote --webengine-schemes=qrc:sLV --lang=en-US: undefined symbol: _ZN7content20localtime_r_overrideEPKlP2tm, version Qt_5
/usr/bin/mendeleydesktop: line 4: 21790 Trace/breakpoint trap   (core dumped) /opt/mendeleydesktop/lib/mendeleydesktop/libexec/mendeleydesktop.x86_64 "$@"

pychuang commented on 2019-10-14 16:29

I don't know if I upgraded the system or did something, but suddenly I couldn't launch Mendeley Desktop. Some issues with the QT library.

In order to use Mendeley again, I have to manually set the runtime QT5 library path to the one included in this bundle, i.e.,

$ export LD_LIBRARY_PATH=/opt/mendeleydesktop/lib/qt

But I don't recall I had to do manually set the path before.

David01 commented on 2019-10-14 13:41

After the latest update, mendeleydektop doesn't work:

Running mendeleydesktop on the terminal yields:

qt5ct: using qt5ct plugin
QFSFileEngine::open: No file name specified
Failed to run mendeley:// link handler installer "/opt/mendeleydesktop/lib/mendeleydesktop/libexec/install-mendeley-link-handler.sh"
/opt/mendeleydesktop/lib/mendeleydesktop/libexec/QtWebEngineProcess --type=zygote --webengine-schemes=qrc:sLV --lang=en-US: symbol lookup error: /opt/mendeleydesktop/lib/mendeleydesktop/libexec/QtWebEngineProcess --type=zygote --webengine-schemes=qrc:sLV --lang=en-US: undefined symbol: _ZN7content20localtime_r_overrideEPKlP2tm, version Qt_5
/usr/bin/mendeleydesktop: line 4:  1642 Trace/breakpoint trap   (core dumped) /opt/mendeleydesktop/lib/mendeleydesktop/libexec/mendeleydesktop.x86_64 "$@"

NekoBuster commented on 2019-08-26 10:03

It doesn't quit properly. When the GUI closes, the process keeps running and its CPU usage flies to 100%. There is a 1.19.5 version released by the upstream and they say some bugs are fixed. Any update plan?

xgdgsc commented on 2019-02-17 13:42

Thanks. Fixed.

jonathon commented on 2019-02-17 11:48

There may be a slight bug in the install-mendeley-link-handler.sh script (https://forum.manjaro.org/t/mendeley-aur-and-ld-library-errors/75931).

This should do the job:

diff --git a/PKGBUILD b/PKGBUILD
index 69ac243..80f8510 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -77,7 +77,7 @@ package_mendeleydesktop-bundled() {
     conflicts=('mendeleydesktop')
     cd "$pkgbase-$pkgver-linux-$CARCH"

-    sed -i 's/Exec=/&LD_LIBRARY_PATH=\/opt\/mendeleydesktop\/lib\/mendeleydesktop\/plugins\/platforms /' bin/install-mendeley-link-handler.sh
+    sed -i 's/Exec=/&env LD_LIBRARY_PATH=\/opt\/mendeleydesktop\/lib\/mendeleydesktop\/plugins\/platforms /' bin/install-mendeley-link-handler.sh

     install -d "$pkgdir/opt/$pkgbase"
     cp -a bin lib share "$pkgdir/opt/$pkgbase/"

It won't replace an existing mendeleydesktop.desktop file but it will help for new users.

blazko commented on 2019-02-17 11:48

Please change line78 of PKGBUILD to:

sed -i 's/Exec=/&env LD_LIBRARY_PATH=\/opt\/mendeleydesktop\/lib\/mendeleydesktop\/plugins\/platforms /' bin/install-mendeley-link-handler.sh

in order to stop ld_library path errors

akstrfn commented on 2019-01-23 20:12

Your whole system does not look healthy...

ilario commented on 2019-01-22 18:31

I'm on an updated 64bit Arch and I'm experiencing frequent Gnome-shell (in libgnome-shell.so) crashes while doing various actions in mendeleydesktop-bundled. Usually this happens when I add a new PDF or when I try to export to a .bib file.

Here the log of the last crash: https://paste.fedoraproject.org/paste/9kk58ZfiICU89QeUUWrumQ

xgdgsc commented on 2019-01-19 16:30

@gaelic I don't see this issue in KDE. Have you checked your ~/.local/share/applications/mendeleydesktop.desktop? I' d suggest you edit it here and use it instead of the one in the package to keep it simple.