Package Base Details: montserrat-font

Git Clone URL: https://aur.archlinux.org/montserrat-font.git (read-only, click to copy)
Submitter: caleb
Maintainer: caleb (chongli)
Last Packager: caleb
Votes: 16
Popularity: 0.060625
First Submitted: 2020-02-24 10:22
Last Updated: 2020-05-28 13:31

Pinned Comments

caleb commented on 2020-02-24 10:00

PSA: I've started hosting this as a prebuilt package in my repository for those that want to install it using pacman without messing around with building from the AUR.

Latest Comments

caleb commented on 2020-02-24 10:00

PSA: I've started hosting this as a prebuilt package in my repository for those that want to install it using pacman without messing around with building from the AUR.

arpitjindal97 commented on 2018-07-16 05:28

This should be the upstream url: https://github.com/JulietaUla/Montserrat

lpapp commented on 2018-06-11 16:19

Upstream url is broken?

caleb commented on 2018-02-16 09:43

@bertptrs This is done now, thanks. I had heard about but also forgotten about the upstream change to handle this with hooks and handn't thought to drop that hot mess.

caleb commented on 2018-02-16 09:27

This package is now up to date. The new upstream release has Cyrillic support, much better extended Latin support, and many more weights. Since this package was really out of date and only had one weight at the time of last update this might not be a huge deal for anybody here, but just a heads up for anybody coming from the 6.x releases that all the weights got re-aligned in the 7.x release and will likely cause reflows. See the project blog entry for details.

bertptrs commented on 2018-02-15 13:22

This package currently runs fc-cache in its post-install hook, but this is wrong for two reasons: - The package doesn't depend on fontconfig, so the command need-not be installed which would cause errors, and - fontconfig itself includes a pacman hook which will automatically run fc-cache when any font is modified, so now fc-cache is run twice.

Could you please remove the install file altogether? It no longer serves its purpose.

caleb commented on 2018-02-15 12:11

This package is out of date and does not include the massive changes in the upstream font including more weights and languages. Check out ttf-montserrat for current fonts. If you want to add me as a maintainer here I can package the same thing in an OTF version.

fupduck commented on 2018-02-02 12:29

Sadly the checksums do not check out. Could you update the package?

eeva commented on 2016-03-27 21:44

Thanks, the PKGBUILD has been updated

nicozone commented on 2016-03-25 20:51

The ttf-montserrat AUR package (version 1.0-1) cannot be installed by yaourt and other AUR helpers because the PKGBUILD file currently has the following errors:

==> Building and installing package
==> ERROR: depends should be an array
==> ERROR: makedepends should be an array
==> ERROR: provides should be an array
==> ERROR: Makepkg was unable to build ttf-montserrat.

I was able to successfully install using yaourt with the following fixed version of PKGBUILD: https://gist.github.com/nelsonni/d408f091e0fea84f7097