Package Base Details: netctl-gui

Git Clone URL: https://aur.archlinux.org/netctl-gui.git (read-only)
Keywords: gui kde netctl network qt
Submitter: arcanis
Maintainer: arcanis
Last Packager: arcanis
Votes: 49
Popularity: 0.173024
First Submitted: 2014-03-25 07:06
Last Updated: 2016-03-10 15:59

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

arcanis commented on 2014-07-22 06:34

When AUR 3.3.0 has been released I've updated PKGBUILD for the new AUR capabilities such as creating split packages. Qt5 stuff (which is qt5-base and qt5-base packages) will be installed as make dependencies and will be no longer needed after building of the package.

Alternative is using my repository [1] (BTW if you don't want add my repository and you don't want install temporary packages you may just download the package from ftp [2]):

[arcanisrepo]
Server = ftp://repo.arcanis.name/repo/$arch

1. https://wiki.archlinux.org/index.php/Unofficial_user_repositories#arcanisrepo
2. ftp://repo.arcanis.name/repo/x86_64/netctl-gui-qt4-1.1.0.ec5dff4-1-x86_64.pkg.tar.xz

P.S. I understand that installation of temporary packages may create some difficulties for users. But I think that updating packages to the new standards is more important than creating of these difficulties and maintaining of the single PKGBUILD is much simpler.

DaveCode commented on 2014-07-22 05:56

I'm puzzled why an upgrade to this qt4 build drags in qt5 stuff?
http://pastebin.archlinux.fr/524147

arcanis commented on 2014-07-21 17:59

NOTE: the current version, which is marked as 'prerelease', is a 'stable' release, but I plan to create a 'stable release' when I will update KDE components for KF5

sl1pkn07 commented on 2014-07-21 08:49

now works. thanks again!

arcanis commented on 2014-07-21 08:03

okay, try to rebuild plasmoid from commit 0070f910c (its tarball is available as 'release'). If you will get this error again, please run

NETCTLGUI_DEBUG=yes plasma-windowed netctl

and post output again.

sl1pkn07 commented on 2014-07-21 06:42

tested new plasmoid. break my desktop

with 'plasma-windowed netctl'

http://sl1pkn07.no-ip.com/paste/view/c34cb055

gretings

sl1pkn07 commented on 2014-07-20 09:59

ok, that file is the reminiscence of old broken config

BTW, i am working in Spanish translation

greetings

arcanis commented on 2014-07-20 09:05

hmm. Disabling and enabling of profiles in my library works through 'netctl {enable,disable} profile'. In my case all thus created files have 644 rights. I don't think that it is a critical message, and I don't sure that it is my bug.

sl1pkn07 commented on 2014-07-20 08:55

works with commit 32683a89 (github), both Qt5 and Qt4 build

greetings :D

NOTE: [ 6.510779] systemd[1]: Configuration file /etc/systemd/system/netctl@Red.service is marked world-inaccessible. This has no effect as configuration data is accessible via APIs without restrictions. Proceeding anyway. -> this message is OK?

arcanis commented on 2014-07-20 08:48

@sl1pkn07
all appearances I've fixed your problem. Try to build now
md5sums=('1d6797070defe45ec7009cb8e4f768c9')