Package Base Details: netctl-gui

Git Clone URL: https://aur.archlinux.org/netctl-gui.git (read-only)
Keywords: gui kde netctl network qt
Submitter: arcanis
Maintainer: arcanis
Last Packager: arcanis
Votes: 49
Popularity: 0.047888
First Submitted: 2014-03-25 07:06
Last Updated: 2016-03-10 15:59

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 Next › Last »

arcanis commented on 2014-07-20 08:40

@sl1pkn07
all appearances I've fixed your problem. Try to build now
md5sums=('e6ad580c9f7fcd593480f14cd93c471c')

arcanis commented on 2014-07-20 07:42

ok, thank you. I'll fix it soon.

sl1pkn07 commented on 2014-07-20 07:22

http://sl1pkn07.no-ip.com/paste/view/be4b9e73

NOTE: i have no wireless in this machine

sl1pkn07 commented on 2014-07-20 07:22

http://sl1pkn07.no-ip.com/paste/view/be4b9e73

arcanis commented on 2014-07-20 07:16

can you attach output for

netctl-gui -d

(any Qt version)

sl1pkn07 commented on 2014-07-20 07:12

in both versions, Qt5 and Qt4 gets segfault with sudo/kdesudo/normal user

gdb Qt5 http://sl1pkn07.no-ip.com/paste/view/a304fc9f
gdb Qt4 http://sl1pkn07.no-ip.com/paste/view/ee9d2fd2

greetings

EDITED: thanks for the pkgbuild

sl1pkn07 commented on 2014-07-20 07:09

in both versions, Qt5 and Qt4 gets segfault with sudo/kdesudo/normal user

gdb http://sl1pkn07.no-ip.com/paste/view/a304fc9f

greetings

EDITED: thanks for the pkgbuild

sl1pkn07 commented on 2014-07-20 07:07

adding

-DBUILD_LIBRARY:BOOL=0 \
-DBUILD_DOCS:BOOL=0 \

in kdeplasma-applets-netctl-gui cmake solve the issue. but in both versions, Qt5 and Qt4 gets segfault with sudo/kdesudo/normal user

gdb http://sl1pkn07.no-ip.com/paste/view/a304fc9f

greetings

arcanis commented on 2014-07-20 06:36

@sl1pkn07, yeah. The correct PKGBUILD for the newest version may be found in the repo [1]. (Since I've detached backend from frontend and added developer documentation.)

Please note that the current 1.2.0 version is a prerelease [2]. I plan to create "stable" release after pushing kf5 packages into the official repository, since I plan to update KDE4 components for the newest Plasma. (But I hope that I will support KDE4 components as long as it's possible.)

1. https://raw.githubusercontent.com/arcan1s/netctl-gui/master/PKGBUILD
2. https://github.com/arcan1s/netctl-gui/releases/tag/V.1.2.0

arcanis commented on 2014-07-20 06:34

@sl1pkn07, yeah. The correct PKGBUILD for the newest version may be found in the repo [1]. (Since I've detached backend from frontend and added developer documentation.)

Please note that the current 1.2.0 version is a prerelease [2]. I plan to create "stable" release after pushing kf5 packages into the official repository, since I plan to update KDE4 components for the newest Plasma.

1. https://raw.githubusercontent.com/arcan1s/netctl-gui/master/PKGBUILD
2. https://github.com/arcan1s/netctl-gui/releases/tag/V.1.2.0