Package Base Details: nvidia-utils-beta

Git Clone URL: https://aur.archlinux.org/nvidia-utils-beta.git (read-only)
Keywords: driver libgl nvidia-settings opencl opengl video vulkan
Submitter: None
Maintainer: dbermond
Last Packager: dbermond
Votes: 338
Popularity: 0.959408
First Submitted: 2008-08-19 21:42
Last Updated: 2019-07-15 01:55

Pinned Comments

dbermond commented on 2019-06-09 03:21

  • Important note:

Package nvidia-egl-wayland-beta was dropped since version 430.14-2.

After updating, replace it with egl-wayland from the official repositories with: pacman -Syu egl-wayland

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8 9 10 11 12 13 ... Next › Last »

Det commented on 2015-02-26 09:30

346.47 — Changelog: http://www.nvidia.com/download/driverResults.aspx/82252/en-us

• Added support for the following GPUs:
   Quadro K620M
   Quadro K2200M
   GeForce GTX 965M
• Fixed a bug that could cause rendering corruption in GLX clients using PBOs and/or VBOs when using GLX indirect rendering.
• Fixed a bug that caused Xinerama layouts which included X screens with 'Option "UseDisplayDevice" "none"' to be represented incorrectly in the nvidia-settings control panel.
• Fixed a bug that could cause glXSwapBuffer() to block for longer than necessary in multi-threaded GLX applications using the GLX_NV_delay_before_swap extension.
• Fixed a bug that caused OpenGL applications using the NV_path_rendering extension to crash after a modeswitch event.
• Fixed a bug that caused DisplayPort audio to stop working after monitors are hotplugged.

Det commented on 2015-02-26 09:30

346.37 — Changelog: http://www.nvidia.com/download/driverResults.aspx/82252/en-us

• Added support for the following GPUs:
   Quadro K620M
   Quadro K2200M
   GeForce GTX 965M
• Fixed a bug that could cause rendering corruption in GLX clients using PBOs and/or VBOs when using GLX indirect rendering.
• Fixed a bug that caused Xinerama layouts which included X screens with 'Option "UseDisplayDevice" "none"' to be represented incorrectly in the nvidia-settings control panel.
• Fixed a bug that could cause glXSwapBuffer() to block for longer than necessary in multi-threaded GLX applications using the GLX_NV_delay_before_swap extension.
• Fixed a bug that caused OpenGL applications using the NV_path_rendering extension to crash after a modeswitch event.
• Fixed a bug that caused DisplayPort audio to stop working after monitors are hotplugged.

Det commented on 2014-12-08 20:42

346.22 - Changelog: http://www.nvidia.com/download/driverResults.aspx/80653

• Added support for X.Org xserver ABI 19 (xorg-server 1.17).
• Improved compatibility with recent Linux kernels.
• Fixed a bug that prevented internal 4K panels on some laptops from being driven at a sufficient bandwidth to support their native resolutions.
• Fixed a regression that prevented the NVIDIA kernel module from loading in some virtualized environments such as Amazon Web Services.
• Fixed a regression that caused displays to be detected incorrectly on some notebook systems.
• Fixed a bug that could cause X to freeze when using Base Mosaic.
• Fixed a regression that prevented the NVIDIA X driver from recognizing Base Mosaic layouts generated by the nvidia-settings control panel.

Det commented on 2014-09-27 02:32

nvidia-beta and nvidia-beta-all both require this package. That sounds like you're somehow trying to remove it.

OffensiveGuin commented on 2014-09-26 15:27

My system wouldn't start X today, giving a nvidia error. I decided to reinstall the nvidia - beta package, but it fails to install nvidia-utils-beta. When nvidia-utils-beta is installed, pacman says "Failed to prepare transaction could not satisfy dependences: nivida-betea requires nvidia-utils-beta" it looks like when you try to install it, it instead tries to install nvidia-beta?

Det commented on 2014-08-12 04:04

We already have that on the driver component itself.

anish commented on 2014-08-12 04:03

A warning for those on nvidia beta drivers, 343 drops support for some older cards, please beware before you install

Det commented on 2014-08-08 10:09

Nice catch that.

anish commented on 2014-08-08 06:06

NVIDIA-Linux-x86_64-343.13-no-compat32.run.part is part of the aurball for some reason, this is causing a bunch of md5sum issues.

==> Download nvidia-utils-beta sources
x NVIDIA-Linux-x86_64-343.13-no-compat32.run.part
x .AURINFO
x PKGBUILD
x 20-nvidia.conf
x nvidia-utils-beta.install

Det commented on 2014-07-09 11:58

340.24 Changelog: http://www.nvidia.com/download/driverResults.aspx/76884

I switched the source to the HTTP mirror, which gives me pretty much the full speed of ~10MB/s, while the FTP one is seemingly capped at 886 kB/s (many times much less). The web interface will still show the FTP mirror (overridden in the .AURINFO), as it gives you a much easier access to all the driver downloads.