Package Base Details: nvidia-vulkan

Git Clone URL: https://aur.archlinux.org/nvidia-vulkan.git (read-only)
Submitter: jcstryker
Maintainer: jcstryker
Last Packager: jcstryker
Votes: 20
Popularity: 1.149522
First Submitted: 2018-06-23 01:17
Last Updated: 2019-07-18 22:11

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

Scindix commented on 2018-11-28 15:49

@ChrizVR Could you post the output of "pacman -Qsq nvidia"?

ChrizVR commented on 2018-11-26 16:05

i get the following error:

looking for conflicting packages... error: unresolvable package conflicts detected error: failed to prepare transaction (conflicting dependencies) :: nvidia-vulkan and nvidia-vulkan-dkms are in conflict ==> WARNING: Failed to install built package(s).

anyone know why?

wyre commented on 2018-11-15 12:17

Yes, right now is fixed and working pretty fine. Thank you @jcstryker

Sorry, @Nocifer, I was confusing with the real maintainer, hehe.

mozo commented on 2018-11-15 08:16

Work like a charm. Thank you :)

jcstryker commented on 2018-11-14 21:40

@Nocifer Thanks for your help! I am going to include Tk-Glitch's patch for kernel 4.19 [0]. His patch is very similar to the two that you provided. Hopefully we get a new vulkan release based on the 410 branch soon.

@wyre Please try the new version. I am running the DKMS version without trouble so far, let me know if you run into issues.

[0] https://github.com/Tk-Glitch/PKGBUILDS/blob/master/nvidia-dev-all/kernel-4.19.patch

jetba commented on 2018-11-14 17:02

@Nocifer Thank you for the patches. I also had success with them on 4.19 kernel, and so far everything is working perfectly.

Nocifer commented on 2018-11-14 15:25

@wyre what do you mean? Of course I applied the patches, that's how I managed to build the package, I just didn't provide the modified PKGBUILD and the two patch files because I wanted to wait for a response from @jcstryker first.

Also, what kind of error does your pacman return? In my case everything built smoothly and all the modules installed correctly, in fact right now I'm booted in a 4.19 system with the nvidia-vulkan modules active. The only problem is that these API changes aren't compatible with the LTS kernel (which I keep installed as a backup), but that's a minor thing. Could it be that you also have the LTS kernel installed, and these errors are produced by it?

wyre commented on 2018-11-14 14:04

lib32-opencl-nvidia-vulkan and lib32-opencl-nvidia-390xx should are in conflict. They are not.

And ... despite of your driver can be compiled and built with those patches ... pacman returns a fail when dkms try to install the module in 4.19 kernel, after the package have been installed. So ... sure, we must wait until nvidia decides merge this features in the main branch.

wyre commented on 2018-11-14 13:33

@Nocifer why did you not modify the PKGBUILD to apply this patchs in prepare()?

Nocifer commented on 2018-11-14 12:23

Alright, I looked it up a bit more and it seems it is indeed a change in the API. Also, apparently the 396.54.09 branch will no longer be supported by Nvidia for kernel 4.19 and above, which presumably means they aim to merge it with the main 410 branch at some point in the near future. When exactly, I obviously couldn't say.

In the meantime, the package can be built with just a couple of minor changes.

https://pastecode.xyz/view/0b9f007e

https://pastecode.xyz/view/a7406bb4