Package Base Details: oss

Git Clone URL: https://aur.archlinux.org/oss.git (read-only, click to copy)
Keywords: oss
Submitter: keenerd
Maintainer: alexdw
Last Packager: alexdw
Votes: 48
Popularity: 0.027025
First Submitted: 2013-09-25 11:25
Last Updated: 2021-01-15 00:09

Packages (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 Next › Last »

kgunders commented on 2015-05-04 15:42

Unfortunate that OSS is broken on 4.x kernels:

Directory preparation complete.
Build ID will be 2011
make: *** No rule to make target 'build'. Stop.
==> ERROR: A failure occurred in build().
Aborting...

alexdw commented on 2015-03-01 23:25

Updated (4.2_2011-1) for build 2011.

@KenjiTakahashi: Thank you for the notification.

alexdw commented on 2014-09-08 19:45

Updated (4.2_2010-2) for build 2010, some clean-up in the PKGBUILD as suggested by nuc (thank you!), use of mkaurball (for new .AURINFO requirement in AUR) and renaming libflashsupport-oss to not conflict with the other ones (seems to be another new AUR requirement).

@nuc: Thanks again for all the information - much appreciated!

nuc commented on 2014-09-04 01:27

Just informing you guys that it is now possible to use Skype with OSS without PulseAudio! You can obtain the corresponding package here -> https://aur.archlinux.org/packages/skype_oss_wrapper-git/
I have also modified the wiki entry for it -> https://wiki.archlinux.org/index.php/Open_Sound_System#Skype
Hope it's ok to post here :)

@alexdw: While you'll be updating the package you might also fix some (minor) stuff on that occasion: In depends/makedepends 'gcc', 'sed', 'make' and 'libtool' are totally redundant since they are part of the base-devel group and thus needed by makepkg anyways (see https://wiki.archlinux.org/index.php/Pkgbuild#makedepends).
Also constantly changing directory into $srcdir is an unnecessary step, since makepkg already switches into that directory by itself (see https://wiki.archlinux.org/index.php/Creating_packages#The_build.28.29_function).
In conflicts, 'oss-linux', 'oss-linux-free' and 'oss-testing' are totally out of date and should be replaced by 'oss-git' and 'oss-nonfree'.
(Of course similar changes need to be done for the other two packages)

Keep up the good work! :)

nuc commented on 2014-09-04 01:08

Just informing you guys that it is now possible to use Skype with OSS without PulseAudio! You can obtain the corresponding package here -> https://aur.archlinux.org/packages/skype_oss_wrapper-git/
I have also modified the wiki entry for it -> https://wiki.archlinux.org/index.php/Open_Sound_System#Skype
Hope it's ok to post here :)

@alexdw: While you'll be updating the package you might also fix some (minor) stuff on that occasion: In makedepends 'gcc' is totally redundant since it is part of the base-devel group and thus needed by makepkg anyways (see https://wiki.archlinux.org/index.php/Pkgbuild#makedepends).
Also constantly changing directory into $srcdir is an unnecessary step, since makepkg already switches into that directory by itself (see https://wiki.archlinux.org/index.php/Creating_packages#The_build.28.29_function).

Keep up the good work! :)

alexdw commented on 2014-09-02 18:03

@nuc: Thanks for the new version notification.

I'll have a look at updating the PKGBUILD to 2010 on Monday - I'm away travelling for work at the moment and won't have access to my primary (Linux) PC until then.

nuc commented on 2014-09-02 16:31

Hm seems they modified the upstream package on 26 August, I wonder why.
However the 2009 build is outdated anyways and the PKGBUILD should be updated to 2010.

rulojuka commented on 2014-09-02 16:04

Hi,

The sha512 checksum failed for oss-v4.2-build2009-src-gpl.tar.bz2

I think the sha512sum is outdated (or just wrong, because none of the files at http://www.4front-tech.com/developer/sources/stable/gpl/ check to the sum in the PKGBUILD)

PKGBUILD: 116df88ffca4515b9fb2b5f25cebc5d5f4aacc26500d387d8db09d38edb4bacb9a82f7b4fe5669ebddbc42ef811eeb2c9a81c2bbd6953c16e7894544c0e6e092

oss-v4.2-build2009-src-gpl.tar.bz2
9fd40ee5ac10b312c97961060b34bb5f4db46eb6d993271f9cd21768910278e6af8b5196638542f25ac287411b42dae8b61c7189637a563c5d6f0bece0e9543d

alexdw commented on 2014-04-14 05:51

@Nowaker: OK, thanks - done. I'll have a look at fixing oss-git (if necessary) some time this week.

@steadybright: If you use the updated package it should work for now. I can't say it will work after every Linux upgrade - 3.8.0, 3.10.0, 3.10.7 and 3.14.0 all caused issues so future upgrades might also.

Nowaker commented on 2014-04-14 01:16

@alexdw, Because you are a maintainer of oss-nonfree, please feel free to adopt this package and oss-git - I just disowned them. Thanks.