Package Base Details: phpstorm

Git Clone URL: https://aur.archlinux.org/phpstorm.git (read-only)
Keywords: development ide php
Submitter: None
Maintainer: freswa
Last Packager: freswa
Votes: 189
Popularity: 0.705927
First Submitted: 2011-01-22 19:28
Last Updated: 2019-06-18 20:54

Packages (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

andoni commented on 2017-03-23 16:39

New version of PHPStorm 2017.1

+pkgver=2017.1
+_pkgver=171.3780.104
+sha512sums=('38d9b49ab60c5e315c4891ec4f0c261028ba7e5012effc174a8e044ed4a6d4052fbde6913815c7dd97b4fcd08852a55b4819bda77a4a8ff476141216a3ef57ee'

kelzax commented on 2017-03-14 23:50

@frederik Thank you

freswa commented on 2017-03-14 23:43

The -jre package contains the jre for phpstorm. It's a split package so anyone who like to use his own jre may not install the jre package.

kelzax commented on 2017-03-14 23:40

I am confused. Is phpstorm-jre a dependency of this package, or a separate repository of the full application with a JRE built in?

- Also, thanks for doing this. The Jetbrains download takes forever.

freswa commented on 2017-02-28 08:59

@marcvanged: pls install phpstorm-jre

marcvangend commented on 2017-02-27 14:08

Since my update today, font rendering looked different, and it was not an improvement. The characters were thin and the anti aliasing caused reddish and greenish edges on the left/right site of the characters. Things looked better after I changed the antialias setting (under 'appearance & behavior > appearance') to "grayscale", but I think it is not exactly how it used to be.

Can this be caused by the split of the package? Is there something else I can try to improve font rendering?

freswa commented on 2017-02-24 21:11

cogux, you also got a message about two new optdepends ;-)

cogux commented on 2017-02-24 17:16

frederik, after update i got a message:
ERROR: Cannot start Phpstorm: No JDK found.

freswa commented on 2017-02-24 14:41

sorry, just fixed that

bruceutut commented on 2017-02-24 14:38

frederik, PKGBUILD file uses rsync for packaging. So rsync should be listed as a makedep at least.