Package Base Details: ppsspp-git

Git Clone URL: https://aur.archlinux.org/ppsspp-git.git (read-only)
Submitter: libcg
Maintainer: alucryd
Last Packager: alucryd
Votes: 39
Popularity: 0.000278
First Submitted: 2012-11-05 20:36
Last Updated: 2019-06-25 08:18

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8 9 10 11 Next › Last »

m45t3r commented on 2013-11-22 21:06

The PKGBUILD is on GitHub for those who want to send a pull request or fork: https://github.com/m45t3r/pkgbuilds

sl1pkn07 commented on 2013-10-18 19:12

the ffmpeg used in ppsspp is a custom ffmpeg. please use it instead of distro package

greetings

robloy_ballobloy commented on 2013-10-03 12:33

This package fails to build for me with the following error:

[ 95%] Building CXX object CMakeFiles/PPSSPPSDL.dir/UI/DevScreens.cpp.o
/home/robbie/ppsspp-git/src/ppsspp/UI/DevScreens.cpp: In member function ‘virtual void SystemInfoScreen::CreateViews()’:
/home/robbie/ppsspp-git/src/ppsspp/UI/DevScreens.cpp:149:2: error: ‘sort’ is not a member of ‘std’
std::sort(exts.begin(), exts.end());
^
/home/robbie/ppsspp-git/src/ppsspp/UI/DevScreens.cpp:157:2: error: ‘sort’ is not a member of ‘std’
std::sort(exts.begin(), exts.end());
^
make[2]: *** [CMakeFiles/PPSSPPSDL.dir/UI/DevScreens.cpp.o] Error 1
make[1]: *** [CMakeFiles/PPSSPPSDL.dir/all] Error 2
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
Aborting...

Does anyone know what's wrong?

someoneelse123 commented on 2013-09-15 16:18

/usr/share/ppsspp/assets/lang is not being installed.

someoneelse123 commented on 2013-09-10 19:10

Hi!
I just submited Mai's Atrac3+ decoder [1] that enables audio playback in movies to AUR and tested briefly (with Danganronpa.) There is small problem though - PPSSPP doesn't detect for decoder presence on Linux.

If you could include this patch [2] in your package, it would save me a lot of manual rebuilding. And it may enable atrac3+ audio for others as well.

[1] https://aur.archlinux.org/packages/mai-at3plus-decoder/
[2] http://pastebin.com/zuveLaX4

Schala commented on 2013-07-31 09:29

Also, when you put in a pkgver() function, be sure to put epoch=1 in the PKGBUILD since Pacman will compare the git revision number to 20130726 and likely believe it to be an older version.

Schala commented on 2013-07-28 23:48

You need to put in a pkgver() function that will auto-set the pkgver. Here's one of mine for an example

pkgver() {
cd "$srcdir/${pkgname%-*}"
echo $(git rev-list --count master)
}

This will set the pkgver to the revision number for the repo.

libcg commented on 2013-07-28 11:08

Schala, I don't understand what you want.

Schala commented on 2013-07-28 01:52

Can you update this for Pacman 4.1? Thanks

libcg commented on 2013-07-26 20:47

Fixed LDFLAGS, fixed dependancies, removed PPSSPPHeadless.