Package Base Details: pulseaudio-hsphfpd

Git Clone URL: https://aur.archlinux.org/pulseaudio-hsphfpd.git (read-only, click to copy)
Submitter: SpineEyE
Maintainer: SpineEyE
Last Packager: SpineEyE
Votes: 9
Popularity: 3.58
First Submitted: 2020-07-16 18:31
Last Updated: 2020-12-30 10:19

Pinned Comments

SpineEyE commented on 2020-11-17 12:35

You need to start the hsphfpd.service from the hsphfpd-git package.

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

rjshrjndrn commented on 2020-12-12 13:37

paru did you mean pacman ?

SpineEyE commented on 2020-12-12 13:03

paru -Syu libpulse-hsphfpd pulseaudio-hsphfpd pulseaudio-bluetooth-hsphfpd pulseaudio-equalizer-hsphfpd pulseaudio-jack-hsphfpd pulseaudio-lirc-hsphfpd pulseaudio-zeroconf-hsphfpd

rjshrjndrn commented on 2020-12-12 12:56

looking for conflicting packages...
:: libpulse-hsphfpd and libpulse are in conflict. Remove libpulse? [y/N] y
:: pulseaudio-hsphfpd and pulseaudio are in conflict. Remove pulseaudio? [y/N] y
:: pulseaudio-bluetooth-hsphfpd and pulseaudio-bluetooth are in conflict. Remove pulseaudio-bluetooth? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing pulseaudio breaks dependency 'pulseaudio=14.0-1' required by pulseaudio-equalizer
:: removing pulseaudio breaks dependency 'pulseaudio=14.0-1' required by pulseaudio-jack
:: removing pulseaudio breaks dependency 'pulseaudio=14.0-1' required by pulseaudio-lirc
:: removing pulseaudio breaks dependency 'pulseaudio=14.0-1' required by pulseaudio-zeroconf

Any solution for this ? Manjaro 20.2

kapiwko commented on 2020-12-10 07:48

Need valgrind available when building to avoid following error.

I've fixed that, now a2dp-codecs and hsphfpd branches are based on latest stable branch, not master.

sadika commented on 2020-12-10 06:37

Need valgrind available when building to avoid following error.

pulseaudio/meson.build:234:6: ERROR: C header 'valgrind/memcheck.h' not found

A full log can be found at /home/sadika/.cache/yay/pulseaudio-hsphfpd/src/build/meson-logs/meson-log.txt
==> ERROR: A failure occurred in build().
    Aborting...
error making: pulseaudio-hsphfpd (libpulse-hsphfpd pulseaudio-hsphfpd pulseaudio-bluetooth-hsphfpd)

gee commented on 2020-12-08 12:00

Good enough, thank you!

SpineEyE commented on 2020-12-07 17:29

To be honest, I'm not sure. I think, this includes functionality from the A2DP merge request, because for my bluetooth headphones I can choose from aptX, SBC low, middle, high, automatic, and extreme quality profile 2. And I don't think A2DP has any more advantages.

gee commented on 2020-12-07 17:13

Does this include Pali's A2Dp's work or only hsphfpd? I only see hsphfpd in the source, but maybe I'm missing something for the extra codecs.

SpineEyE commented on 2020-12-07 16:52

I think it's in Pali's interest that people use his code. He only struggles with the PulseAudio maintainers. If he wants me to take down this package, he can write me.

annisar commented on 2020-12-07 10:46

I am sorry but I do not think that using someone's work without consent in (even AUR) a package is appropriate and Pali withdrawn his patches for well known reason. Of course, nothing stops you from using the saved branch in your PKGBUILD using for an example @jennydaman's patch, but there's an ongoing drama and I believe that the packages shouldn't be updated until Pali agrees to.