Package Base Details: pyside2-git

Git Clone URL: https://aur.archlinux.org/pyside2-git.git (read-only)
Submitter: drhooves
Maintainer: Cebtenzzre
Last Packager: Cebtenzzre
Votes: 2
Popularity: 0.000083
First Submitted: 2017-03-03 08:15
Last Updated: 2019-03-01 21:27

Latest Comments

« First ‹ Previous 1 2 3 4

sheinz commented on 2017-05-31 13:58

If you have errors similar as I described for shiboken2 https://aur.archlinux.org/packages/python-shiboken2-git/
The solution also applies here. (Use 5.6 branch)

Kunda commented on 2017-03-14 19:43

My bad. I didn't realize that the qt5.6 had been recently bumped. I went ahead and built it and it took forever... for some reason it failed but I think it was a hardware issue on my side. So I need to find a window to recompile it and see if it builds. Thanks for your help so far!

drhooves commented on 2017-03-12 14:29

Are you certain that you rebuilt qt5.6? The installed version should be 5.6.2-3. If thats the case please pm me the output of `pacman -Ql qt5.6` and the complete build log of pyside2.

Kunda commented on 2017-03-12 14:16

Build failed:

[ 97%] Building CXX object PySide2/QtWebEngineWidgets/CMakeFiles/QtWebEngineWidgets.dir/PySide2/QtWebEngineWidgets/qwebenginecertificateerror_wrapper.cpp.o
c++: error: /tmp/pamac-build-ghee/pyside2-git/src/pyside2-git/build-py2/PySide2/QtWebEngineWidgets/PySide2/QtWebEngineWidgets/qwebenginecertificateerror_wrapper.cpp: No such file or directory
c++: fatal error: no input files
compilation terminated.
make[2]: *** [PySide2/QtWebEngineWidgets/CMakeFiles/QtWebEngineWidgets.dir/build.make:105: PySide2/QtWebEngineWidgets/CMakeFiles/QtWebEngineWidgets.dir/PySide2/QtWebEngineWidgets/qwebenginecertificateerror_wrapper.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:1660: PySide2/QtWebEngineWidgets/CMakeFiles/QtWebEngineWidgets.dir/all] Error 2
make: *** [Makefile:128: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...

drhooves commented on 2017-03-12 13:17

Everything should work now. Unfortunately you have to rebuild qt5.6 and qt5.6-webkit. Not sure about shiboken2 but it builds pretty fast so I recommend to rebuild it too.

drhooves commented on 2017-03-11 08:50

Hi Kunda, just a missing dependency, fixed now. Thanks for reporting.
However I just discovered a bigger issue with the qt5.6 package. It doesn't always (depends on whats installed on the system, maybe your lucky ;) ) build QWebEngine which means that pyside will try to link against the official qt5 (5.8) qwebengine, which won't work. A workaround is to uninstall qt5-webengine or build in a clean chroot. I will try to resolve the issue in the coming days.

Kunda commented on 2017-03-11 03:35

Can't build.
Error log from pamac and includes log from /tmp/pamac-build-ghee/pyside2-git/src/pyside2-git/build-py2/CMakeFiles/CMakeOutput.log
https://gist.github.com/luzpaz/e78bbf49e61943083622a6419e03a50a