Package Base Details: python-github3.py

Git Clone URL: https://aur.archlinux.org/python-github3.py.git (read-only)
Submitter: ColinDuquesnoy
Maintainer: abdo
Last Packager: abdo
Votes: 3
Popularity: 0.005853
First Submitted: 2015-02-19 17:23
Last Updated: 2019-04-27 13:44

Latest Comments

mnieto commented on 2019-04-27 13:22

I disowned this package as I can no longer maintain it.

abdo commented on 2019-04-27 09:59

This package is missing dependencies on python-dateutil (community) and python-jwcrypto (AUR)

abdo commented on 2018-07-24 18:08

The python-uritemplate.py dependency of this packages is already in community: https://www.archlinux.org/packages/community/any/python-uritemplate/ I think there is no need to depend on the AUR version.

abdo commented on 2017-03-13 07:58

> This package is meant to depend on python-uritemplate.py, but that dependency is not declared properly

This is a split package, and the dependency is declared allright. It seems to be a problem with yaourt that is not able to handle dependencies on split packages:

https://github.com/archlinuxfr/yaourt/issues/85

> Also, is there any notable difference between this package and python-github3

Yeah. python-github3 is the same package at version 0.9.6, while this one is at 1.0a4 (alpha state). Unfortunately, there is a ton of API breakage between those two, and upstream does not seem close to a stable 1.0 yet.

marsoft commented on 2017-03-13 07:33

This package is meant to depend on python-uritemplate.py, but that dependency is not declared properly and is not handled by yaourt.
Also, is there any notable difference between this package and python-github3?

mnieto commented on 2016-10-11 11:59

> nrujac flagged python-github3.py out-of-date on 2016-07-25
> for the following reason:
>
> setup.py is trying to write to /usr/lib/python3.X causing a
> permissions error. I suspect this is an upstream problem, but
> it means the package can't currently be built.
>

nrujac, I cannot reproduce the issue. Sorry for the delay, for some reason I did not get notified about the flag.

I'll try again after upgrading my system. But if you can provide some extra detail it would be great.