Package Base Details: python-llvmlite-git

Git Clone URL: https://aur.archlinux.org/python-llvmlite-git.git (read-only, click to copy)
Submitter: guotsuan
Maintainer: guotsuan
Last Packager: guotsuan
Votes: 3
Popularity: 0.000473
First Submitted: 2014-11-30 03:15
Last Updated: 2019-05-30 00:43

Latest Comments

1 2 Next › Last »

petronny commented on 2020-05-04 02:50

Hi could you drop python2-llvmlite-git?

It doesn't build now and Python 2 is EOL.

==> Starting package_python2-llvmlite-git()...
/usr/lib/python2.7/site-packages/setuptools/dist.py:476: UserWarning: Normalizing '0.33.0dev0+17.gc4f5a08' to '0.33.0.dev0+17.gc4f5a08'
  normalized_version,
running install
running build
got version from VCS {'version': '0.33.0dev0+17.gc4f5a08', 'full': 'c4f5a085c9f9c7a192579b02a11347bfc2ac768b'}
running build_ext
/usr/bin/python2 /build/python-llvmlite-git/src/llvmlite-py2/ffi/build.py
  File "/build/python-llvmlite-git/src/llvmlite-py2/ffi/build.py", line 122
    raise ValueError(msg.format(_ver_check_skip)) from e
                                                     ^
SyntaxError: invalid syntax
error: command '/usr/bin/python2' failed with exit status 1

petronny commented on 2019-11-30 01:29

python-llvmlite-git depends on llvm but python-llvmlite doesn't (it's only a make dependency). Please fix this.

flying-sheep commented on 2019-11-22 15:51

@guotsuan please fix that, and also it’s --root="$pkgdir", not --root=$pkgdir

petronny commented on 2019-06-04 05:10

@guotsuan It's not provides=('python-llvmlite=$pkgver'). It should be provides=("python-llvmlite=$pkgver").

guotsuan commented on 2019-05-30 00:43

Thanks, I have fixed it.

petronny commented on 2019-05-29 06:01

@guotsuan So please updating provides=('python-llvmlite') to provides=("python-llvmlite=$pkgver")

flying-sheep commented on 2019-05-24 08:22

It does work!

petronny commented on 2019-05-23 05:58

@flying-sheep Could you confirm if this can be fixed by updating provides=('python-llvmlite') to provides=("python-llvmlite=$pkgver") in line 32?

flying-sheep commented on 2019-05-22 12:31

Hmm, pacman doesn’t seem to understand this version number.

With python-llvmlite-git-0.29.0dev0.r36.gd5e5cb0-1 installed, I see:

$ cd python-numba
$ makepkg -i
==> Missing dependencies:
  -> python-llvmlite>=0.28.0

guotsuan commented on 2016-02-19 17:31

@lonaowna: Thanks. I have updated the PKGBUILD include the 'python2-enum34'
And yes, Numba seems to work finally with newest numba code and llvmlite-git based on llvm 3.7!!