Package Base Details: python-numpy-openblas

Git Clone URL: https://aur.archlinux.org/python-numpy-openblas.git (read-only)
Submitter: xia0er
Maintainer: xia0er
Last Packager: xia0er
Votes: 23
Popularity: 0.065115
First Submitted: 2013-11-21 20:38
Last Updated: 2019-04-15 02:52

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

xia0er commented on 2015-11-09 19:51

@ewtoombs Indeed. This seems to be a problem caused by putting depends inside the package() function - probably related to the problem @mnick experienced as well. I now moved it along with other parameters outside the function.

ewtoombs commented on 2015-10-18 21:33

For some reason, makepkg -si doesn't install cython as a dependency. This results in the build failure that you might expect to see. Is this a problem with makepkg or with this PKGBUILD?

xia0er commented on 2015-01-09 22:18

gcc-fortran is specified in the makedepends in package_python-numpy-openblas and package_python2-numpy-openblas function.

mnick commented on 2015-01-09 21:27

The PKGBUILD is missing a build dependency to gcc-fortran. The same holds for the python2 package.

xia0er commented on 2014-12-22 00:24

Just a note, you can check whether numpy built with this package is optimized utilizing openblas by checking whether numpy's lapack_lite library is linked with the openblas library:

$ ldd /usr/lib/python2.7/site-packages/numpy/linalg/lapack_lite.so
...
libopenblas.so.3 => /usr/lib/libopenblas.so.3
...

Of course running benchmarks would give you some idea as well.

sftrytry commented on 2014-10-06 01:38

It seems 1.9.0 is released.

xia0er commented on 2014-08-11 17:47

numpy now requires openblas to be configured in site.cfg for it to be successfully compiled with openblas.

xia0er commented on 2014-08-11 17:46

numpy now requires openblas to be configured in site.cfg for it to be successfully compiled with openblas.

xia0er commented on 2014-06-19 23:15

Before I figure out how to work around the "Error - all directories must have permissions of 755" when uploading to AUR, the src package is at: https://dl.dropboxusercontent.com/u/142634/python-numpy-openblas-1.8.1-2.src.tar.gz

xia0er commented on 2014-06-19 23:12

sftrytry and vidar, thanks for identifying the problem. I created a new src package with site.cfg included, but I have to shamefully admit I don't know how to successfully upload a src package to aur anymore with this new version. It complains that "Error - all directories must have permissions of 755", but I am pretty sure all files in and directory int the src package are either 644 or 755. I put the src package at dropbox for now: https://dl.dropboxusercontent.com/u/142634/python2-numpy-openblas-1.8.1-2.src.tar.gz