Package Base Details: python-numpy-openblas

Git Clone URL: https://aur.archlinux.org/python-numpy-openblas.git (read-only)
Submitter: xia0er
Maintainer: xia0er
Last Packager: xia0er
Votes: 23
Popularity: 0.066444
First Submitted: 2013-11-21 20:38
Last Updated: 2019-04-15 02:52

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

sftrytry commented on 2014-06-18 04:02

@vidar
How can I add cat command in PKGBUILD. I added your script above python2 setup.py stuff but got PKGBUILD syntax error of EOF.

sftrytry commented on 2014-05-17 17:10

2nd vidar.
I updated my numpy on May 17. It was not optimized.

vidar commented on 2014-05-15 10:56

Hello. There is a little flaw in the PKGBUILD. numpy is NOT automatically linked against openblas, I added this to the PKGBUILD just above the python2 setup.py lines and it worked:
(the standard prefix for my openblas-lapack package was /usr )

cat <<-EOF > site.cfg
[openblas]
libraries = openblas
library_dirs = /usr/lib
include_dirs = /usr/include
EOF

xia0er commented on 2014-04-10 21:43

@stalafin, linking against openblas is now handled automatically when numpy is being built from source if openblas-lapack is installed (no change to numpy files needed, not even to site.cfg). I'd imagine it should similar for scipy.

Stalafin commented on 2014-02-25 19:51

How did you do to get Numpy to link against OpenBlas?

I checked the Numpy sources, and in its site.cfg.example there is an example on how to get it to link against OpenBlas. However, your PKGBUILD appears to use the default site.cfg.

I am trying to have Scipy link against OpenBlas as well, but I don't understand how to achieve that. Any hints?

uboot commented on 2014-02-20 12:45

options=("staticlibs") required, packages like scipy won't build otherwise...

uboot commented on 2014-02-20 12:45

options=("staticlibs") required, packages like scipy won't build otherwise...

uboot commented on 2014-02-20 11:04

options=("staticlibs") required, otherwise packages like python-scipy-git won't build

uboot commented on 2014-02-20 11:03

options=("staticlibs") required, otherwise packages like python-scipy-git won't build

xia0er commented on 2013-12-09 17:45

As compiling with openblas support is now handled upstream in numpy, this packages is only needed to indicate the dependency of openblas-lapack package (as openblas package doesn't do it) and do a build of numpy after openblas-lapack is installed.