Package Base Details: python-powerline-git

Git Clone URL: https://aur.archlinux.org/python-powerline-git.git (read-only)
Submitter: Lokaltog
Maintainer: gbs
Last Packager: gbs
Votes: 134
Popularity: 0.000845
First Submitted: 2013-01-23 07:28
Last Updated: 2018-10-10 20:08

Latest Comments

« First ‹ Previous ... 6 7 8 9 10 11 12 Next › Last »

Lokaltog commented on 2013-03-12 11:38

Sure. I don't have that path on my system and other OTF fonts have been installed in TTF/ so I assumed it was the standard. I'll change it.

kuroneko commented on 2013-03-12 00:29

Can you move the font to be installed in OTF/ instead of TTF/?

Lokaltog commented on 2013-03-08 17:07

The PKGBUILD and license has been updated. Thanks for your comments.

Lokaltog commented on 2013-03-04 15:36

Thanks for the comments, I'll look into this asap.

bluepill commented on 2013-03-04 15:17

The installation instruction in powerline.install gives a wrong hint for enabling powerline for tmux.
The correct command to add to .tmux.conf should be:
source-file '/usr/share/tmux/powerline.conf'
instead of
source '/usr/share/tmux/powerline.conf'

Also, as mentioned by AndreasBWagner, it's necessary to manually set the PYTHONPATH variable.

cgirard commented on 2013-03-04 14:42

I'm not sure why you set pkgbase. It makes "makepkg -S" generate the files in a python-powerline directory instead of python-powerline-git. This is not standard PKGBUILD behavior and results in malfunction with AUR helpers.

bluepill commented on 2013-03-04 14:09

The installation instruction in powerline.install gives a wrong hint for enabling powerline for tmux.
The correct command to add to .tmux.conf should be:
source-file '/usr/share/tmux/powerline.conf'
instead of
source '/usr/share/tmux/powerline.conf'

Also, as mentioned by AndreasBWagner, it's necessary to manually set the PYTHONPATH variable.

jsteel commented on 2013-02-28 12:52

vim-powerline-git has merged with this package, I suggest adding that to replaces.

jsteel commented on 2013-02-28 12:50

Merging to python-powerline-git

Profpatsch commented on 2013-02-21 22:36

With the python2 version I got a lot of “eval did not return a valid python object”, but with this I get
“An error occured while importing the Powerline package. This could be caused by an invalid sys.path setting, or by an incompatible Python version (Powerline requires Python 2.7 or 3.3+ to work). Please consult the troubleshooting section in the documentation for possible solutions.”

All packages are their newest versions. I’ll try installing it via Vundle next.