Flagged Out-of-Date Comment: python2-pyxdg

MarsSeed flagged python2-pyxdg out-of-date on 2024-04-09 (UTC) for the following reason:

Remove unneeded dummy subpackage python2-xdg.