Package Base Details: qemu-patched

Git Clone URL: https://aur.archlinux.org/qemu-patched.git (read-only)
Submitter: Vaporeon
Maintainer: jonpas
Last Packager: jonpas
Votes: 13
Popularity: 0.225292
First Submitted: 2017-11-01 12:37
Last Updated: 2019-07-08 11:44

Pinned Comments

Vaporeon commented on 2018-05-09 08:10

The -headless packages conflict with the normal builds intentionally and are not meant to be installed together. Some AUR helpers don't handle this well and will attempt to install all built packages at once.

Saren commented on 2018-04-19 15:16

Just do $ gpg --recv-key 3353C9CEF108B584

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

alegru commented on 2018-08-20 16:15

@Larf I had the same problem, and could workaround it by disabling nic offloading features on the host. Might be worth a try: ethtool -K eth0 tx off rx off

Larf commented on 2018-05-19 10:02

I loose network after some time with kinda heavy usage. Does anybody experience the same issue? I sometimes get bluescreens about driver powerstates. I use Virtio but i will try e1000. This only happened after the latest qemu-patched update.

Vaporeon commented on 2018-05-09 08:10

The -headless packages conflict with the normal builds intentionally and are not meant to be installed together. Some AUR helpers don't handle this well and will attempt to install all built packages at once.

polarathene commented on 2018-04-30 05:23

I am having trouble installing this package to replace normal qemu package.

Resolving dependencies... Checking inter-conflicts... Error: unresolvable package conflicts detected

Failed to prepare transaction: conflicting dependencies: qemu-patched-headless-arch-extra and qemu-patched-arch-extra are in conflict

Neither of them are installed, so it must have something to do with this package? I tried to install qemu-patched-headless and got a similar problem..

Resolving dependencies... Checking inter-conflicts...

Failed to prepare transaction: could not satisfy dependencies: unable to satisfy dependency 'qemu-headless' required by qemu-patched-headless-arch-extra

How to resolve?

EdLin commented on 2018-04-22 17:38

Tried downgrading llvm and clang to the ones in arch repositories, no joy, same error.

EdLin commented on 2018-04-22 16:47

OK, I tried to compile it using an earlier GCC I had in my /var/cache/pacman/pkg (from March by the looks of it), it still had the same error compiling.

EdLin commented on 2018-04-20 22:23

I'm having this error while compiling: CC util/module.o /tmp/trizen-edlin/qemu-patched/src/qemu-2.11.1/util/memfd.c:40:12: error: static declaration of ‘memfd_create’ follows non-static declaration static int memfd_create(const char name, unsigned int flags) ^~~~~~~~~~~~ In file included from /usr/include/bits/mman-linux.h:115:0, from /usr/include/bits/mman.h:45, from /usr/include/sys/mman.h:41, from /tmp/trizen-edlin/qemu-patched/src/qemu-2.11.1/include/sysemu/os-posix.h:29, from /tmp/trizen-edlin/qemu-patched/src/qemu-2.11.1/include/qemu/osdep.h:104, from /tmp/trizen-edlin/qemu-patched/src/qemu-2.11.1/util/memfd.c:28: /usr/include/bits/mman-shared.h:46:5: note: previous declaration of ‘memfd_create’ was here int memfd_create (const char name, unsigned int flags) __THROW; ^~~~~~~~~~~~ make: [/tmp/trizen-edlin/qemu-patched/src/qemu-2.11.1/rules.mak:66: util/memfd.o] Error 1 make: Waiting for unfinished jobs.... ==> ERROR: A failure occurred in build(). Aborting... :: Unable to build qemu-patched - makepkg exited with code: 2

I can't right now compile qemu-patched. Am runnining the testing repo for pacman (so testing's gcc), and am running clang/llvm from SVN for using mesa-git (needed for my AMD Ryzen APU).

Saren commented on 2018-04-19 15:16

Just do $ gpg --recv-key 3353C9CEF108B584

getaceres commented on 2018-04-09 10:17

Building fails with:

==> Verifying source file signatures with gpg...

qemu-2.11.1.tar.xz ... FAILED (unknown public key 3353C9CEF108B584)

==> ERROR: One or more PGP signatures could not be verified!

MungFuSensei commented on 2018-04-04 05:35

It seems the keys need to be updated?