Package Base Details: qgnomeplatform-git

Git Clone URL: (read-only, click to copy)
Submitter: spider-mario
Maintainer: spider-mario
Last Packager: spider-mario
Votes: 30
Popularity: 0.012345
First Submitted: 2016-02-03 22:32 (UTC)
Last Updated: 2023-11-07 10:28 (UTC)

Latest Comments

1 2 3 Next › Last »

MarsSeed commented on 2024-04-01 14:30 (UTC)

As this is both EOL since last year and continues to fail to build during the past 6 months or so, I think it is safe to delete at this point.

It has no reverse dependencies.

Upstream's successor project is qadwaitadecorations, with both Qt5 & Qt6 support.

Muflone commented on 2024-04-01 14:28 (UTC)

missing make-dependency qqc2-desktop-style5

leonardof commented on 2023-10-29 15:55 (UTC) (edited on 2023-10-29 16:49 (UTC) by leonardof)

Couldn't build this package even after installing its dependencies. Not using any AUR helper.

$ LC_ALL=C makepkg --clean
==> Making package: qgnomeplatform-git 0.7.0.r99.gd86d6ba-1 (Sun Oct 29 12:50:17 2023)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Updating QGnomePlatform git repo...
==> Validating source files with sha256sums...
    QGnomePlatform ... Skipped
==> Extracting sources...
  -> Creating working copy of QGnomePlatform git repo...
Reset branch 'makepkg'
==> Starting pkgver()...
==> Removing existing $pkgdir/ directory...
==> Starting build()...
CMake Warning (dev) at CMakeLists.txt:1 (project):
  cmake_minimum_required() should be called prior to this top-level project()
  call.  Please see the cmake-commands(7) manual for usage documentation of
  both commands.
This warning is for project developers.  Use -Wno-dev to suppress it.

CMake Deprecation Warning at CMakeLists.txt:3 (cmake_minimum_required):
  Compatibility with CMake < 3.5 will be removed from a future version of

  Update the VERSION argument <min> value or use a ...<max> suffix to tell
  CMake that the project does not need compatibility with older versions.

CMake Error at /usr/lib/cmake/Qt5/Qt5Config.cmake:28 (find_package):
  Could not find a package configuration file provided by "Qt5QuickControls2"
  with any of the following names:


  Add the installation prefix of "Qt5QuickControls2" to CMAKE_PREFIX_PATH or
  set "Qt5QuickControls2_DIR" to a directory containing one of the above
  files.  If "Qt5QuickControls2" provides a separate development package or
  SDK, be sure it has been installed.
Call Stack (most recent call first):
  CMakeLists.txt:34 (find_package)

-- Configuring incomplete, errors occurred!
==> ERROR: A failure occurred in build().
$ cmake --version
cmake version 3.27.7

CMake suite maintained and supported by Kitware (

Installing extra/qqc2-desktop-style5 fixes the error.

q234rty commented on 2023-06-06 07:17 (UTC)

Currently the two built packages conflict, this needs something like

Taijian commented on 2022-09-15 09:01 (UTC)

@q234rty: OK, I fixed the non-building issue by making adwaita-qt5-git also provide adwaita-qt-git

q234rty commented on 2022-09-14 11:40 (UTC)

This currently doesn't build because adwaita-qt-git has been split into adwaita-qt5-git and adwaita-qt6-git.

Taijian commented on 2022-09-04 15:21 (UTC)

Could you update this to build both the qt5 and the qt6 version of the package, just like the one in the main repo does?

moshiur_rahman commented on 2020-10-03 05:46 (UTC)

Oh, did not know that. I was using yay to install qgnomeplatform-git and it showed dependency error. I guess I'll have to edit the PKGBUILD and manually install it since yay checks for dependency before allowing you to edit the PKGBUILD.

yochananmarqos commented on 2020-10-03 01:54 (UTC)

@moshiur: VCS packages build from the latest commit no matter what the PKGBUILD version is.

moshiur_rahman commented on 2020-10-02 16:40 (UTC)

There is no adwaita-qt-git>=1.1.4.r22.gef1ba6a in the AUR so the package fails to build due to dependency error. The adwaita-qt-git pack in the AUR has version 1.1.1.r1.gd1e7619-2. adwaita-qt however has version 1.1.4-2.