Package Base Details: roccat-tools

Git Clone URL: https://aur.archlinux.org/roccat-tools.git (read-only)
Keywords: gui hardware keyboard mouse settings
Submitter: russo79
Maintainer: aaronfischer
Last Packager: aaronfischer
Votes: 55
Popularity: 0.325209
First Submitted: 2012-03-05 16:53
Last Updated: 2019-05-16 20:50

Pinned Comments

aaronfischer commented on 2019-03-28 20:13

@Gonzo2028: See here: https://www.reddit.com/r/linux_gaming/comments/5js1l2/im_stefan_achatz_stopping_programming_linux/

Stunts commented on 2017-01-05 13:13

@gonzo2028:
There are 2 alternative ways:
1. @aaronfischer splits the package into 25 different ones and whenever there is an update he will have to update 25 individual packages; good for the useres, not so good for the maintainer.
2. @aaronfischer "merges" all the files from the split packages into a single package. This will result in installing binaries, udev rules and .desktop files for 25 devices for every user. Less work for the maintainer, not practical for the users.

As is it, the maintainer maintains one single "split-package" and users that use an AUR helper such as yaourt, can uninstall the packages they don't need. This way users get to keep only the files they need to support their own device and the maintainer does not have to modify and commit 25 packages every time there is an update.

Hope this helps clear it.

aaronfischer commented on 2015-11-22 13:21

@edward_81: Please read the previous comments here. I've talked to Stefan about this. Every version of roccat-tools need a specific version of libgaminggear to work correctly. There are two options here: Consistent/reliable package and a little bit of hasle on upgrades -- or easy upgrade process and the chance of a broken package with weird bugs everywhere. I've choosen the first option.

edward_81 commented on 2015-10-03 15:31

Is possible to change the dependency line for libgaminggear from:
libgaminggear=0.11.1
to:
libgaminggear>=0.11.1
Because every time i try to upgrade the system with yaourt/aur, it complain that roccat-tool-common need that exactly version of libgaminggear.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

foxhunt72 commented on 2018-07-02 12:39

Get a issue building:

[ 9%] Linking C executable roccateventhandler /usr/lib/gcc/x86_64-pc-linux-gnu/8.1.1/../../../../lib/libgaminggear.so: undefined reference to sqlite3_close@SQLITE_3' /usr/lib/gcc/x86_64-pc-linux-gnu/8.1.1/../../../../lib/libgaminggear.so: undefined reference tosqlite3_exec@SQLITE_3' /usr/lib/gcc/x86_64-pc-linux-gnu/8.1.1/../../../../lib/libgaminggear.so: undefined reference to sqlite3_free@SQLITE_3' /usr/lib/gcc/x86_64-pc-linux-gnu/8.1.1/../../../../lib/libgaminggear.so: undefined reference tosqlite3_open@SQLITE_3' collect2: error: ld returned 1 exit status make[2]: [roccateventhandler/CMakeFiles/roccateventhandler.dir/build.make:152: roccateventhandler/roccateventhandler] Error 1 make[1]: [CMakeFiles/Makefile2:398: roccateventhandler/CMakeFiles/roccateventhandler.dir/all] Error 2 make: *** [Makefile:141: all] Error 2 ==> ERROR: A failure occurred in build(). Aborting... The build failed.

aaronfischer commented on 2018-05-17 21:36

There was a cmake version bump, which killed a definition file for libgaminggear. Please reinstall libgaminggear to get the correct definition file on the correct place, so you can guild roccat-tools.

Davikar commented on 2018-05-15 08:52

I get the same error message as @Freso. I've tried rebuilding libgaminggear, but it doesn't help...

Poohblah commented on 2018-03-28 00:45

@Freso, I had the same issue. I fixed it by rebuilding and reinstalling the libgaminggear AUR package.

StefanT commented on 2018-02-19 17:45

For me this package requires that I also install roccat-tools-ryosmk. Otherwise the configuration fails to start:

$ roccatryosmkfxconfig

roccatryosmkfxconfig: error while loading shared libraries:

libroccatryosmkwidget.so.5: cannot open shared object file: No such file or directory

Freso commented on 2018-02-03 02:42

I get an error trying to makepkg this PKGBUILD: """ freso@din /t/f/roccat-tools> makepkg -fscC ==> Making package: roccat-tools 5.7.0-1 (Sat Feb 3 03:39:35 CET 2018) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Found roccat-tools-5.7.0.tar.bz2 -> Found 90-uinput.rules -> Found uhid.conf ==> Validating source files with sha256sums... roccat-tools-5.7.0.tar.bz2 ... Passed 90-uinput.rules ... Passed uhid.conf ... Passed ==> Removing existing $srcdir/ directory... ==> Extracting sources... -> Extracting roccat-tools-5.7.0.tar.bz2 with bsdtar ==> Removing existing $pkgdir/ directory... ==> Starting build()... CMake Deprecation Warning at CMakeLists.txt:3 (CMAKE_POLICY): The OLD behavior for policy CMP0022 will be removed from a future version of CMake.

The cmake-policies(7) manual explains that the OLD behaviors of all policies are deprecated and that a policy should be set to OLD only under specific short-term circumstances. Projects should be ported to the NEW behavior and not rely on setting a policy to OLD.

-- The C compiler identification is GNU 7.3.0 -- Check for working C compiler: /usr/lib/ccache/bin/cc -- Check for working C compiler: /usr/lib/ccache/bin/cc -- works -- Detecting C compiler ABI info -- Detecting C compiler ABI info - done -- Detecting C compile features -- Detecting C compile features - done -- compiling for devices arvo;isku;iskufx;kiro;koneplus;konepure;konepuremilitary;konepureoptical;konextd;konextdoptical;kovaplus;kova2016;lua;nyth;pyra;ryosmk;ryosmkfx;ryostkl;savu;skeltr;sova;suora;tyon;kone -- Installing libraries in /usr/lib -- Installing udev rules in /usr/lib/udev/rules.d -- Installing eventhandler plugins in /usr/lib/roccat -- Compiler supports attribute pack -- Found PkgConfig: /usr/bin/pkg-config (found version "0.29.2") -- Checking for module 'gthread-2.0' -- Found gthread-2.0, version 2.54.3 -- Checking for module 'atk' -- Found atk, version 2.26.1 -- Checking for module 'cairo' -- Found cairo, version 1.15.10 -- Checking for module 'gdk-2.0' -- Found gdk-2.0, version 2.24.32 -- Checking for module 'gdk-pixbuf-2.0' -- Found gdk-pixbuf-2.0, version 2.36.10 -- Checking for module 'glib-2.0' -- Found glib-2.0, version 2.54.3 -- Checking for module 'gobject-2.0' -- Found gobject-2.0, version 2.54.3 -- Checking for module 'gtk+-2.0' -- Found gtk+-2.0, version 2.24.32 -- Checking for module 'pango' -- Found pango, version 1.40.13 -- Checking for module 'dbus-1' -- Found dbus-1, version 1.12.2 -- Checking for module 'dbus-glib-1' -- Found dbus-glib-1, version 0.110 -- Checking for module 'gmodule-2.0' -- Found gmodule-2.0, version 2.54.3 -- Checking for module 'gudev-1.0' -- Found gudev-1.0, version 232 -- Checking for module 'x11' -- Found x11, version 1.6.5 CMake Error at CMakeLists.txt:84 (FIND_PACKAGE): By not providing "FindGAMINGGEAR0.cmake" in CMAKE_MODULE_PATH this project has asked CMake to find a package configuration file provided by "GAMINGGEAR0", but CMake did not find one.

Could not find a package configuration file provided by "GAMINGGEAR0" (requested version 0.15.1) with any of the following names:

GAMINGGEAR0Config.cmake
gaminggear0-config.cmake

Add the installation prefix of "GAMINGGEAR0" to CMAKE_PREFIX_PATH or set "GAMINGGEAR0_DIR" to a directory containing one of the above files. If "GAMINGGEAR0" provides a separate development package or SDK, be sure it has been installed.

-- Configuring incomplete, errors occurred! See also "/tmp/makepkg/roccat-tools/src/roccat-tools-5.7.0/CMakeFiles/CMakeOutput.log". ==> ERROR: A failure occurred in build(). Aborting... """

DarkSkyGhost commented on 2017-01-17 16:42

Removing infinality font bundle allowed roccat to build properly, it seems infinality is no longer supported/updated, see more info here:

https://bbs.archlinux.org/viewtopic.php?id=221648

To remove infinality:

sudo pacman -S freetype2 fontconfig lib32-freetype2 lib32-fontconfig lib32-cairo

maxyme commented on 2017-01-08 03:36

Edit: It seems harfbuzz 1.4.1 broke this package's build. Using 1.3.4 works fine.

With most recent update I'm getting the following error:

[ 10%] Linking C executable roccatarvoconfig
/usr/lib/libharfbuzz.so.0: undefined reference to `FT_Get_Var_Blend_Coordinates'
collect2: error: ld returned 1 exit status
make[2]: *** [arvo/roccatarvoconfig/CMakeFiles/roccatarvoconfig.dir/build.make:291: arvo/roccatarvoconfig/roccatarvoconfig] Error 1
make[1]: *** [CMakeFiles/Makefile2:809: arvo/roccatarvoconfig/CMakeFiles/roccatarvoconfig.dir/all] Error 2
make: *** [Makefile:139: all] Error 2


I have harfbuzz, harfbuzz-icu and lib32-harfbuzz installed.

ryuzy commented on 2017-01-06 13:58

@Gonzo2028:
If you use an AUR helper like pacaur only the specified packages will be installed and not all of them.

mdemierre commented on 2017-01-05 15:52

@aaronfischer I think you forgot to include the new 90-uinput.rules in your latest commit (f2f8e2eef25ab4c880828b9fadf7b5829c5130d9). It still has the old checksum.