Package Base Details: roccat-tools

Git Clone URL: https://aur.archlinux.org/roccat-tools.git (read-only)
Keywords: gui hardware keyboard mouse settings
Submitter: russo79
Maintainer: aaronfischer
Last Packager: aaronfischer
Votes: 55
Popularity: 0.209570
First Submitted: 2012-03-05 16:53
Last Updated: 2019-05-16 20:50

Pinned Comments

aaronfischer commented on 2019-03-28 20:13

@Gonzo2028: See here: https://www.reddit.com/r/linux_gaming/comments/5js1l2/im_stefan_achatz_stopping_programming_linux/

Stunts commented on 2017-01-05 13:13

@gonzo2028:
There are 2 alternative ways:
1. @aaronfischer splits the package into 25 different ones and whenever there is an update he will have to update 25 individual packages; good for the useres, not so good for the maintainer.
2. @aaronfischer "merges" all the files from the split packages into a single package. This will result in installing binaries, udev rules and .desktop files for 25 devices for every user. Less work for the maintainer, not practical for the users.

As is it, the maintainer maintains one single "split-package" and users that use an AUR helper such as yaourt, can uninstall the packages they don't need. This way users get to keep only the files they need to support their own device and the maintainer does not have to modify and commit 25 packages every time there is an update.

Hope this helps clear it.

aaronfischer commented on 2015-11-22 13:21

@edward_81: Please read the previous comments here. I've talked to Stefan about this. Every version of roccat-tools need a specific version of libgaminggear to work correctly. There are two options here: Consistent/reliable package and a little bit of hasle on upgrades -- or easy upgrade process and the chance of a broken package with weird bugs everywhere. I've choosen the first option.

edward_81 commented on 2015-10-03 15:31

Is possible to change the dependency line for libgaminggear from:
libgaminggear=0.11.1
to:
libgaminggear>=0.11.1
Because every time i try to upgrade the system with yaourt/aur, it complain that roccat-tool-common need that exactly version of libgaminggear.

Latest Comments

« First ‹ Previous ... 6 7 8 9 10 11 12 13 14 15 16 ... Next › Last »

AnAkkk commented on 2014-07-11 20:15

I've reported roccateventhandler crash and it was fixed in the development branch. I still have these permission errors though, with both roccateventhandler and device configs, if they're not ran as root.

AnAkkk commented on 2014-07-11 10:19

Every time I launch the Isku config, the following error shows up:
Error opening /dev/hidraw1: Permission non accordée
(means: Access denied)
For savu, it's similar:
Error opening /dev/hidraw2: Permission non accordée

I have noticed that "roccateventhandler" keeps crashing as well. I have tried to launch it manually:
(roccateventhandler:26171): GamingGear-WARNING **: Error connecting canberra context: No such driver
Erreur de segmentation
(means: Segmentation fault)

von commented on 2014-07-09 13:56

I just removed the old roccat-tools packages and installed the new ones. It's not like I use them all the time anyway.

von commented on 2014-07-09 13:55

I just removed the old roccat-tools packages and installed the new ones.

pdq commented on 2014-07-09 02:33

How did you guys upgrade these packages? Installed fresh? Using --force doesn't seem to work with pacman -U and libgaminggear because it's not the package being installed that has depends issues it's the existing/already installed roccat-tools package.

If it's changed to >= then one would be able to upgrade libgaminggear to 0.4.0 while still having previous roccat-tools installed, which would then allow roccat-tools to get updated at the same time and after the libgaminggear. I cannot do this for the current PKGBUILD cause I'm still stuck using the old packages.

If you could graciously link us to the previous roccat-tools PKGBUILD? Then we'd be able to modify it from =0.3.0 to >=0.3.0 and then reinstall the old/existing package and then we'd be able to upgrade/install to this latest version and also do the same for that.

= to >= otherwise this problem will arise next time the package(s) need updating. I not think this is any problem because you maintain both packages and the next time there is an update needing specific versions you control it. :] Thanks.

aaronfischer commented on 2014-07-08 18:31

@Von, @pdq: The problem is that all roccat-tools NEED libgaminggear in version 0.4.0 and will not work with 0.3.0. So >= will fix the upgrade-problem, but is not correct :/ Is there no other solution sane for this problem?

von commented on 2014-07-08 12:04

I'm pretty sure roccat-tools is only needed for the configuration of roccat hardware. The kernel should have all the required drivers shipped with it since liek 3.0?

Another option is to make package depend on >=version instead of ==version, so that the future versions of the dependency won't be prevented from being installed.

pdq commented on 2014-07-08 00:53

Thanks for reply aaronmueller :] Do you have a copy of the previous versions PKGBUILD? If I could get that and then change 'libgaminggear=0.3.0' to 'libgaminggear>=0.3.0' and then reinstall my existing roccat-tools then I think this will solve all the problems as the dependencies would be solved and it would allow the upgrade path?

aaronfischer commented on 2014-07-07 21:40

@pdq: This is indeed a problem :( The problem is, that the roccat-tools (all subpackages) depend on libgaminggear 0.4.0, so there is no other way to solve upgrade yourself :(

I think your roccat keyboard should "work" (type commands) without any roccat-* package. If you are using yaourt, you can try to ignore the dependencies with --force and install the new version of libgaminggear and then roccat-tools-common, roccat-tools-YOUR-KEYBOARD. This is not a sane solution, I know, if zomeone had a better Idea, lat me know.

pdq commented on 2014-07-07 21:17

Von, thanks but I had tried and have just now tried that again. I don't see how it is possible to upgrade libgaminggear or roccat-tools as it exists now with such strict package versioning depends without using force flag or removing packages. I sure don't want to remove packages that are responsible for me being able to have input. :P

On both my desktops I cannot upgrade libgaminggear to 0.4.0 because existing roccat-tools depends on libgaminggear=0.3.0 and I cannot upgrade roccat-tools because it depends on libgaminggear=0.4.0.
Is there some safe method of upgrading these packages? :)