Package Base Details: roccat-tools

Git Clone URL: (read-only, click to copy)
Keywords: gui hardware keyboard mouse settings
Submitter: russo79
Maintainer: aaronfischer
Last Packager: aaronfischer
Votes: 57
Popularity: 0.90
First Submitted: 2012-03-05 16:53
Last Updated: 2020-09-23 21:17

Pinned Comments

aaronfischer commented on 2019-03-28 20:13

@Gonzo2028: See here:

Stunts commented on 2017-01-05 13:13

There are 2 alternative ways:
1. @aaronfischer splits the package into 25 different ones and whenever there is an update he will have to update 25 individual packages; good for the useres, not so good for the maintainer.
2. @aaronfischer "merges" all the files from the split packages into a single package. This will result in installing binaries, udev rules and .desktop files for 25 devices for every user. Less work for the maintainer, not practical for the users.

As is it, the maintainer maintains one single "split-package" and users that use an AUR helper such as yaourt, can uninstall the packages they don't need. This way users get to keep only the files they need to support their own device and the maintainer does not have to modify and commit 25 packages every time there is an update.

Hope this helps clear it.

aaronfischer commented on 2015-11-22 13:21

@edward_81: Please read the previous comments here. I've talked to Stefan about this. Every version of roccat-tools need a specific version of libgaminggear to work correctly. There are two options here: Consistent/reliable package and a little bit of hasle on upgrades -- or easy upgrade process and the chance of a broken package with weird bugs everywhere. I've choosen the first option.

edward_81 commented on 2015-10-03 15:31

Is possible to change the dependency line for libgaminggear from:
Because every time i try to upgrade the system with yaourt/aur, it complain that roccat-tool-common need that exactly version of libgaminggear.

Latest Comments

« First ‹ Previous ... 7 8 9 10 11 12 13 14 15 16 17 ... Next › Last »

erazor commented on 2014-09-27 06:55

That libgaminggear specifity is caused by me. At the moment libgaminggears interface is constantly changing, hence it's major version 0 and the one-version-of-libgaminggear-for-one-version-of-roccat-tools dependency. I'm hoping to end this inconvenience in the near future.

von commented on 2014-09-25 20:39

also any specific reason to depend on specific version of libgaminggear? Why not use libgaminggear>=0.4.0 instead of libgaminggear=0.4.0 ? Updating to newer libgaminggear in your case requires either removal of roccat-tools or breaking deps.

von commented on 2014-09-25 20:28

You can subscribe to updates on sourceforge you know. And get email with each new release on the projects you follow. A very useful feature for a maintainer.

AnAkkk commented on 2014-07-11 20:21

I've removed my comments because I found out the issue: my user was no longer in the group "roccat".

AnAkkk commented on 2014-07-11 20:15

I've reported roccateventhandler crash and it was fixed in the development branch. I still have these permission errors though, with both roccateventhandler and device configs, if they're not ran as root.

AnAkkk commented on 2014-07-11 10:19

Every time I launch the Isku config, the following error shows up:
Error opening /dev/hidraw1: Permission non accordée
(means: Access denied)
For savu, it's similar:
Error opening /dev/hidraw2: Permission non accordée

I have noticed that "roccateventhandler" keeps crashing as well. I have tried to launch it manually:
(roccateventhandler:26171): GamingGear-WARNING **: Error connecting canberra context: No such driver
Erreur de segmentation
(means: Segmentation fault)

von commented on 2014-07-09 13:56

I just removed the old roccat-tools packages and installed the new ones. It's not like I use them all the time anyway.

von commented on 2014-07-09 13:55

I just removed the old roccat-tools packages and installed the new ones.

pdq commented on 2014-07-09 02:33

How did you guys upgrade these packages? Installed fresh? Using --force doesn't seem to work with pacman -U and libgaminggear because it's not the package being installed that has depends issues it's the existing/already installed roccat-tools package.

If it's changed to >= then one would be able to upgrade libgaminggear to 0.4.0 while still having previous roccat-tools installed, which would then allow roccat-tools to get updated at the same time and after the libgaminggear. I cannot do this for the current PKGBUILD cause I'm still stuck using the old packages.

If you could graciously link us to the previous roccat-tools PKGBUILD? Then we'd be able to modify it from =0.3.0 to >=0.3.0 and then reinstall the old/existing package and then we'd be able to upgrade/install to this latest version and also do the same for that.

= to >= otherwise this problem will arise next time the package(s) need updating. I not think this is any problem because you maintain both packages and the next time there is an update needing specific versions you control it. :] Thanks.

aaronfischer commented on 2014-07-08 18:31

@Von, @pdq: The problem is that all roccat-tools NEED libgaminggear in version 0.4.0 and will not work with 0.3.0. So >= will fix the upgrade-problem, but is not correct :/ Is there no other solution sane for this problem?