Package Base Details: roccat-tools

Git Clone URL: https://aur.archlinux.org/roccat-tools.git (read-only)
Keywords: gui hardware keyboard mouse settings
Submitter: russo79
Maintainer: aaronfischer
Last Packager: aaronfischer
Votes: 55
Popularity: 0.203657
First Submitted: 2012-03-05 16:53
Last Updated: 2019-05-16 20:50

Pinned Comments

aaronfischer commented on 2019-03-28 20:13

@Gonzo2028: See here: https://www.reddit.com/r/linux_gaming/comments/5js1l2/im_stefan_achatz_stopping_programming_linux/

Stunts commented on 2017-01-05 13:13

@gonzo2028:
There are 2 alternative ways:
1. @aaronfischer splits the package into 25 different ones and whenever there is an update he will have to update 25 individual packages; good for the useres, not so good for the maintainer.
2. @aaronfischer "merges" all the files from the split packages into a single package. This will result in installing binaries, udev rules and .desktop files for 25 devices for every user. Less work for the maintainer, not practical for the users.

As is it, the maintainer maintains one single "split-package" and users that use an AUR helper such as yaourt, can uninstall the packages they don't need. This way users get to keep only the files they need to support their own device and the maintainer does not have to modify and commit 25 packages every time there is an update.

Hope this helps clear it.

aaronfischer commented on 2015-11-22 13:21

@edward_81: Please read the previous comments here. I've talked to Stefan about this. Every version of roccat-tools need a specific version of libgaminggear to work correctly. There are two options here: Consistent/reliable package and a little bit of hasle on upgrades -- or easy upgrade process and the chance of a broken package with weird bugs everywhere. I've choosen the first option.

edward_81 commented on 2015-10-03 15:31

Is possible to change the dependency line for libgaminggear from:
libgaminggear=0.11.1
to:
libgaminggear>=0.11.1
Because every time i try to upgrade the system with yaourt/aur, it complain that roccat-tool-common need that exactly version of libgaminggear.

Latest Comments

« First ‹ Previous ... 7 8 9 10 11 12 13 14 15 16 17 ... Next › Last »

pdq commented on 2014-07-07 21:12

Von, I tried that. I dunno how one can proceed without removing packages or forcing install of packages when existing package 'roccat-tools-common' depends on libgaminggear=0.3.0 while the latest update 'roccat-tools' depends on libgaminggear=0.4.0?
Is there something I can edit the PKGBUILD to so my systems are able to upgrade from libgaminggear 0.3 to libgaminggear 0.4 and upgrade roccat-tools 2.0 to roccat-tools 2.1?

pdq commented on 2014-07-07 21:08

Von, I tried that. I dunno how one can proceed without removing packages or forcing install of packages when existing package 'roccat-tools-common' depends on libgaminggear=0.3.0 while the latest update 'roccat-tools' depends on libgaminggear=0.4.0?

von commented on 2014-07-07 07:31

Sorry for those two comments, I was either confused or it was fixed while I was sleeping, I'm removing them either way.

pdq, if it fails to install automatically, try downloading PKGBUILDs and running makepkg manually.

von commented on 2014-07-07 05:03

error: target not found: libgaminggear=0.4.0

Tried to install that one?

pdq commented on 2014-07-07 01:23

[pacaur -Syua]
:: looking for inter-conflicts...

AUR Packages (13): libgaminggear-0.4.0-2 roccat-tools-arvo-2.1.0-1 roccat-tools-common-2.1.0-1 roccat-tools-isku-2.1.0-1 roccat-tools-iskufx-2.1.0-1 roccat-tools-kone-2.1.0-1 roccat-tools-koneplus-2.1.0-1 roccat-tools-konepure-2.1.0-1 roccat-tools-konextd-2.1.0-1 roccat-tools-kovaplus-2.1.0-1 roccat-tools-lua-2.1.0-1 roccat-tools-pyra-2.1.0-1 roccat-tools-savu-2.1.0-1

:: Proceed with installation? [Y/n] y
:: Retrieving package(s)...
:: View roccat-tools PKGBUILD? [Y/n] n
:: View roccat-tools.install script? [Y/n] n
:: Installing libgaminggear cached package...
loading packages...
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: roccat-tools-common: requires libgaminggear=0.3.0
:: Building roccat-tools-arvo,roccat-tools-common,roccat-tools-isku,roccat-tools-iskufx,roccat-tools-kone,roccat-tools-koneplus,roccat-tools-konepure,roccat-tools-konextd,roccat-tools-kovaplus,roccat-tools-lua,roccat-tools-pyra,roccat-tools-savu package(s)...
==> Making package: roccat-tools 2.1.0-1 (Sun Jul 6 20:22:16 CDT 2014)
==> Checking runtime dependencies...
==> Installing missing dependencies...
error: target not found: libgaminggear=0.4.0
==> ERROR: 'pacman' failed to install missing dependencies.
:: roccat-tools cleaned

Seems it's impossible to update this package?

pdq commented on 2014-07-07 01:17

:: looking for inter-conflicts...
AUR Packages (13): libgaminggear-0.4.0-2 roccat-tools-arvo-2.1.0-1 roccat-tools-common-2.1.0-1 roccat-tools-isku-2.1.0-1 roccat-tools-iskufx-2.1.0-1 roccat-tools-kone-2.1.0-1 roccat-tools-koneplus-2.1.0-1 roccat-tools-konepure-2.1.0-1 roccat-tools-konextd-2.1.0-1 roccat-tools-kovaplus-2.1.0-1 roccat-tools-lua-2.1.0-1 roccat-tools-pyra-2.1.0-1 roccat-tools-savu-2.1.0-1

:: Proceed with installation? [Y/n] y
:: Retrieving package(s)...
:: View roccat-tools PKGBUILD? [Y/n] n
:: View roccat-tools.install script? [Y/n] n
:: Installing libgaminggear cached package...
loading packages...
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: roccat-tools-common: requires libgaminggear=0.3.0
:: Building roccat-tools-arvo,roccat-tools-common,roccat-tools-isku,roccat-tools-iskufx,roccat-tools-kone,roccat-tools-koneplus,roccat-tools-konepure,roccat-tools-konextd,roccat-tools-kovaplus,roccat-tools-lua,roccat-tools-pyra,roccat-tools-savu package(s)...
==> Making package: roccat-tools 2.1.0-1 (Sun Jul 6 20:10:13 CDT 2014)
==> Checking runtime dependencies...
==> Installing missing dependencies...
error: target not found: libgaminggear=0.4.0
==> ERROR: 'pacman' failed to install missing dependencies.
:: roccat-tools cleaned

Upgrading this package seems impossible?

von commented on 2014-07-06 23:00

--- PKGBUILD.original 2014-07-06 23:45:59.000000000 +0400
+++ PKGBUILD.fixed 2014-07-07 02:53:56.631990397 +0400
@@ -22,7 +22,7 @@
cd "${srcdir}/${pkgname}-${pkgver}/"
make DESTDIR="${pkgdir}" install

- if [[ -d "${pkgdir}/usr/share/cmake" ]]; then
- mv ${pkgdir}/usr/share/cmake{,-3.0}
+ if [[ -d "${pkgdir}/usr/share/cmake-2.8" ]]; then
+ mv ${pkgdir}/usr/share/cmake{-2.8,-3.0}
fi
}

von commented on 2014-07-06 22:57

25,26c25,26
< if [[ -d "${pkgdir}/usr/share/cmake" ]]; then
< mv ${pkgdir}/usr/share/cmake{,-3.0}
---
> if [[ -d "${pkgdir}/usr/share/cmake-2.8" ]]; then
> mv ${pkgdir}/usr/share/cmake{-2.8,-3.0}

von commented on 2014-07-06 22:51

CMake Error at CMakeLists.txt:63 (FIND_PACKAGE):
By not providing "FindGAMINGGEAR0.cmake" in CMAKE_MODULE_PATH this project
has asked CMake to find a package configuration file provided by
"GAMINGGEAR0", but CMake did not find one.

Could not find a package configuration file provided by "GAMINGGEAR0"
(requested version 0.4.0) with any of the following names:

GAMINGGEAR0Config.cmake
gaminggear0-config.cmake

Add the installation prefix of "GAMINGGEAR0" to CMAKE_PREFIX_PATH or set
"GAMINGGEAR0_DIR" to a directory containing one of the above files. If
"GAMINGGEAR0" provides a separate development package or SDK, be sure it
has been installed.

aaronfischer commented on 2014-07-06 12:44

@fr0stb1te: I've fixed the problem with the missing cmake rule. cmake 3.0 is now a strict dependency.

Bumped to version 2.1. Let me know if there are any problems (can't test fully, have not all hardware here)