Package Base Details: roccat-tools

Git Clone URL: https://aur.archlinux.org/roccat-tools.git (read-only, click to copy)
Keywords: gui hardware keyboard mouse settings
Submitter: russo79
Maintainer: aaronfischer
Last Packager: aaronfischer
Votes: 57
Popularity: 0.49
First Submitted: 2012-03-05 16:53
Last Updated: 2020-09-23 21:17

Pinned Comments

aaronfischer commented on 2019-03-28 20:13

@Gonzo2028: See here: https://www.reddit.com/r/linux_gaming/comments/5js1l2/im_stefan_achatz_stopping_programming_linux/

Stunts commented on 2017-01-05 13:13

@gonzo2028:
There are 2 alternative ways:
1. @aaronfischer splits the package into 25 different ones and whenever there is an update he will have to update 25 individual packages; good for the useres, not so good for the maintainer.
2. @aaronfischer "merges" all the files from the split packages into a single package. This will result in installing binaries, udev rules and .desktop files for 25 devices for every user. Less work for the maintainer, not practical for the users.

As is it, the maintainer maintains one single "split-package" and users that use an AUR helper such as yaourt, can uninstall the packages they don't need. This way users get to keep only the files they need to support their own device and the maintainer does not have to modify and commit 25 packages every time there is an update.

Hope this helps clear it.

aaronfischer commented on 2015-11-22 13:21

@edward_81: Please read the previous comments here. I've talked to Stefan about this. Every version of roccat-tools need a specific version of libgaminggear to work correctly. There are two options here: Consistent/reliable package and a little bit of hasle on upgrades -- or easy upgrade process and the chance of a broken package with weird bugs everywhere. I've choosen the first option.

edward_81 commented on 2015-10-03 15:31

Is possible to change the dependency line for libgaminggear from:
libgaminggear=0.11.1
to:
libgaminggear>=0.11.1
Because every time i try to upgrade the system with yaourt/aur, it complain that roccat-tool-common need that exactly version of libgaminggear.

Latest Comments

« First ‹ Previous ... 8 9 10 11 12 13 14 15 16 17 18 ... Next › Last »

von commented on 2014-07-08 12:04

I'm pretty sure roccat-tools is only needed for the configuration of roccat hardware. The kernel should have all the required drivers shipped with it since liek 3.0?

Another option is to make package depend on >=version instead of ==version, so that the future versions of the dependency won't be prevented from being installed.

pdq commented on 2014-07-08 00:53

Thanks for reply aaronmueller :] Do you have a copy of the previous versions PKGBUILD? If I could get that and then change 'libgaminggear=0.3.0' to 'libgaminggear>=0.3.0' and then reinstall my existing roccat-tools then I think this will solve all the problems as the dependencies would be solved and it would allow the upgrade path?

aaronfischer commented on 2014-07-07 21:40

@pdq: This is indeed a problem :( The problem is, that the roccat-tools (all subpackages) depend on libgaminggear 0.4.0, so there is no other way to solve upgrade yourself :(

I think your roccat keyboard should "work" (type commands) without any roccat-* package. If you are using yaourt, you can try to ignore the dependencies with --force and install the new version of libgaminggear and then roccat-tools-common, roccat-tools-YOUR-KEYBOARD. This is not a sane solution, I know, if zomeone had a better Idea, lat me know.

pdq commented on 2014-07-07 21:17

Von, thanks but I had tried and have just now tried that again. I don't see how it is possible to upgrade libgaminggear or roccat-tools as it exists now with such strict package versioning depends without using force flag or removing packages. I sure don't want to remove packages that are responsible for me being able to have input. :P

On both my desktops I cannot upgrade libgaminggear to 0.4.0 because existing roccat-tools depends on libgaminggear=0.3.0 and I cannot upgrade roccat-tools because it depends on libgaminggear=0.4.0.
Is there some safe method of upgrading these packages? :)

pdq commented on 2014-07-07 21:12

Von, I tried that. I dunno how one can proceed without removing packages or forcing install of packages when existing package 'roccat-tools-common' depends on libgaminggear=0.3.0 while the latest update 'roccat-tools' depends on libgaminggear=0.4.0?
Is there something I can edit the PKGBUILD to so my systems are able to upgrade from libgaminggear 0.3 to libgaminggear 0.4 and upgrade roccat-tools 2.0 to roccat-tools 2.1?

pdq commented on 2014-07-07 21:08

Von, I tried that. I dunno how one can proceed without removing packages or forcing install of packages when existing package 'roccat-tools-common' depends on libgaminggear=0.3.0 while the latest update 'roccat-tools' depends on libgaminggear=0.4.0?

von commented on 2014-07-07 07:31

Sorry for those two comments, I was either confused or it was fixed while I was sleeping, I'm removing them either way.

pdq, if it fails to install automatically, try downloading PKGBUILDs and running makepkg manually.

von commented on 2014-07-07 05:03

error: target not found: libgaminggear=0.4.0

Tried to install that one?

pdq commented on 2014-07-07 01:23

[pacaur -Syua]
:: looking for inter-conflicts...

AUR Packages (13): libgaminggear-0.4.0-2 roccat-tools-arvo-2.1.0-1 roccat-tools-common-2.1.0-1 roccat-tools-isku-2.1.0-1 roccat-tools-iskufx-2.1.0-1 roccat-tools-kone-2.1.0-1 roccat-tools-koneplus-2.1.0-1 roccat-tools-konepure-2.1.0-1 roccat-tools-konextd-2.1.0-1 roccat-tools-kovaplus-2.1.0-1 roccat-tools-lua-2.1.0-1 roccat-tools-pyra-2.1.0-1 roccat-tools-savu-2.1.0-1

:: Proceed with installation? [Y/n] y
:: Retrieving package(s)...
:: View roccat-tools PKGBUILD? [Y/n] n
:: View roccat-tools.install script? [Y/n] n
:: Installing libgaminggear cached package...
loading packages...
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: roccat-tools-common: requires libgaminggear=0.3.0
:: Building roccat-tools-arvo,roccat-tools-common,roccat-tools-isku,roccat-tools-iskufx,roccat-tools-kone,roccat-tools-koneplus,roccat-tools-konepure,roccat-tools-konextd,roccat-tools-kovaplus,roccat-tools-lua,roccat-tools-pyra,roccat-tools-savu package(s)...
==> Making package: roccat-tools 2.1.0-1 (Sun Jul 6 20:22:16 CDT 2014)
==> Checking runtime dependencies...
==> Installing missing dependencies...
error: target not found: libgaminggear=0.4.0
==> ERROR: 'pacman' failed to install missing dependencies.
:: roccat-tools cleaned

Seems it's impossible to update this package?

pdq commented on 2014-07-07 01:17

:: looking for inter-conflicts...
AUR Packages (13): libgaminggear-0.4.0-2 roccat-tools-arvo-2.1.0-1 roccat-tools-common-2.1.0-1 roccat-tools-isku-2.1.0-1 roccat-tools-iskufx-2.1.0-1 roccat-tools-kone-2.1.0-1 roccat-tools-koneplus-2.1.0-1 roccat-tools-konepure-2.1.0-1 roccat-tools-konextd-2.1.0-1 roccat-tools-kovaplus-2.1.0-1 roccat-tools-lua-2.1.0-1 roccat-tools-pyra-2.1.0-1 roccat-tools-savu-2.1.0-1

:: Proceed with installation? [Y/n] y
:: Retrieving package(s)...
:: View roccat-tools PKGBUILD? [Y/n] n
:: View roccat-tools.install script? [Y/n] n
:: Installing libgaminggear cached package...
loading packages...
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: roccat-tools-common: requires libgaminggear=0.3.0
:: Building roccat-tools-arvo,roccat-tools-common,roccat-tools-isku,roccat-tools-iskufx,roccat-tools-kone,roccat-tools-koneplus,roccat-tools-konepure,roccat-tools-konextd,roccat-tools-kovaplus,roccat-tools-lua,roccat-tools-pyra,roccat-tools-savu package(s)...
==> Making package: roccat-tools 2.1.0-1 (Sun Jul 6 20:10:13 CDT 2014)
==> Checking runtime dependencies...
==> Installing missing dependencies...
error: target not found: libgaminggear=0.4.0
==> ERROR: 'pacman' failed to install missing dependencies.
:: roccat-tools cleaned

Upgrading this package seems impossible?