Package Base Details: roccat-tools

Git Clone URL: https://aur.archlinux.org/roccat-tools.git (read-only, click to copy)
Keywords: gui hardware keyboard mouse settings
Submitter: russo79
Maintainer: aaronfischer
Last Packager: aaronfischer
Votes: 57
Popularity: 0.60
First Submitted: 2012-03-05 16:53
Last Updated: 2020-09-23 21:17

Pinned Comments

aaronfischer commented on 2019-03-28 20:13

@Gonzo2028: See here: https://www.reddit.com/r/linux_gaming/comments/5js1l2/im_stefan_achatz_stopping_programming_linux/

Stunts commented on 2017-01-05 13:13

@gonzo2028:
There are 2 alternative ways:
1. @aaronfischer splits the package into 25 different ones and whenever there is an update he will have to update 25 individual packages; good for the useres, not so good for the maintainer.
2. @aaronfischer "merges" all the files from the split packages into a single package. This will result in installing binaries, udev rules and .desktop files for 25 devices for every user. Less work for the maintainer, not practical for the users.

As is it, the maintainer maintains one single "split-package" and users that use an AUR helper such as yaourt, can uninstall the packages they don't need. This way users get to keep only the files they need to support their own device and the maintainer does not have to modify and commit 25 packages every time there is an update.

Hope this helps clear it.

aaronfischer commented on 2015-11-22 13:21

@edward_81: Please read the previous comments here. I've talked to Stefan about this. Every version of roccat-tools need a specific version of libgaminggear to work correctly. There are two options here: Consistent/reliable package and a little bit of hasle on upgrades -- or easy upgrade process and the chance of a broken package with weird bugs everywhere. I've choosen the first option.

edward_81 commented on 2015-10-03 15:31

Is possible to change the dependency line for libgaminggear from:
libgaminggear=0.11.1
to:
libgaminggear>=0.11.1
Because every time i try to upgrade the system with yaourt/aur, it complain that roccat-tool-common need that exactly version of libgaminggear.

salsadoom commented on 2014-05-19 19:31

Doesn't seem to compile for me... libgaminggear is installed, though. Thanks for maintaining this package!

CMake Error at CMakeLists.txt:55 (FIND_PACKAGE):
By not providing "FindGAMINGGEAR0.cmake" in CMAKE_MODULE_PATH this project
has asked CMake to find a package configuration file provided by
"GAMINGGEAR0", but CMake did not find one.

Could not find a package configuration file provided by "GAMINGGEAR0"
(requested version 0.2.0) with any of the following names:

GAMINGGEAR0Config.cmake
gaminggear0-config.cmake

Add the installation prefix of "GAMINGGEAR0" to CMAKE_PREFIX_PATH or set
"GAMINGGEAR0_DIR" to a directory containing one of the above files. If
"GAMINGGEAR0" provides a separate development package or SDK, be sure it
has been installed.

salsadoom commented on 2014-05-19 19:30

Doesn't seem to compile for me...

CMake Error at CMakeLists.txt:55 (FIND_PACKAGE):
By not providing "FindGAMINGGEAR0.cmake" in CMAKE_MODULE_PATH this project
has asked CMake to find a package configuration file provided by
"GAMINGGEAR0", but CMake did not find one.

Could not find a package configuration file provided by "GAMINGGEAR0"
(requested version 0.2.0) with any of the following names:

GAMINGGEAR0Config.cmake
gaminggear0-config.cmake

Add the installation prefix of "GAMINGGEAR0" to CMAKE_PREFIX_PATH or set
"GAMINGGEAR0_DIR" to a directory containing one of the above files. If
"GAMINGGEAR0" provides a separate development package or SDK, be sure it
has been installed.

aaronfischer commented on 2014-05-12 20:16

Thanks for your suggestion AnAkkk! I've added a meta package roccat-tools until AUR 3.0 gives native support for split packages. So to stay updated, install the roccat-tools meta package.

I've also removed the \r Stuff from the install file.

von commented on 2014-05-10 21:40

roccat-tools.install needs to get rid of \r's ;)

von commented on 2014-05-10 21:34

getting this error while installing roccat-tools-common:

/tmp/alpm_BdZiiu/.INSTALL: line 1: syntax error near unexpected token `$'{\r''
'tmp/alpm_BdZiiu/.INSTALL: line 1: `post_install() {

von commented on 2014-05-04 13:20

Would be awesome if this PKGBUILD included a meta package without any deps just for the sake of tracking the updates.

Also 1.5.1 has just been released.

AnAkkk commented on 2014-05-01 18:07

Installing this package doesn't create a package called "roccat-tools", so yaourt never detects when there is an update to it, unfortunately.

aaronfischer commented on 2014-04-17 22:38

Updated version to 1.5.0.
MAke sure to install the new dependency 'libgaminggear' (i've made a AUR package) first.

Anonymous comment on 2014-04-14 07:54

New Released 1.5.0

aaronfischer commented on 2014-04-02 12:27

Thanks for your bug reports, It's fixed now.