Package Base Details: roccat-tools

Git Clone URL: https://aur.archlinux.org/roccat-tools.git (read-only, click to copy)
Keywords: gui hardware keyboard mouse settings
Submitter: russo79
Maintainer: aaronfischer
Last Packager: aaronfischer
Votes: 57
Popularity: 0.60
First Submitted: 2012-03-05 16:53
Last Updated: 2020-09-23 21:17

Pinned Comments

aaronfischer commented on 2019-03-28 20:13

@Gonzo2028: See here: https://www.reddit.com/r/linux_gaming/comments/5js1l2/im_stefan_achatz_stopping_programming_linux/

Stunts commented on 2017-01-05 13:13

@gonzo2028:
There are 2 alternative ways:
1. @aaronfischer splits the package into 25 different ones and whenever there is an update he will have to update 25 individual packages; good for the useres, not so good for the maintainer.
2. @aaronfischer "merges" all the files from the split packages into a single package. This will result in installing binaries, udev rules and .desktop files for 25 devices for every user. Less work for the maintainer, not practical for the users.

As is it, the maintainer maintains one single "split-package" and users that use an AUR helper such as yaourt, can uninstall the packages they don't need. This way users get to keep only the files they need to support their own device and the maintainer does not have to modify and commit 25 packages every time there is an update.

Hope this helps clear it.

aaronfischer commented on 2015-11-22 13:21

@edward_81: Please read the previous comments here. I've talked to Stefan about this. Every version of roccat-tools need a specific version of libgaminggear to work correctly. There are two options here: Consistent/reliable package and a little bit of hasle on upgrades -- or easy upgrade process and the chance of a broken package with weird bugs everywhere. I've choosen the first option.

edward_81 commented on 2015-10-03 15:31

Is possible to change the dependency line for libgaminggear from:
libgaminggear=0.11.1
to:
libgaminggear>=0.11.1
Because every time i try to upgrade the system with yaourt/aur, it complain that roccat-tool-common need that exactly version of libgaminggear.

goniz commented on 2014-03-27 20:38

Was able to install roccat-tools-konextd after repacking koneplus package with "provides = koneplus"

Vash63 commented on 2014-03-23 01:33

Same issue as bluezero4 has here. Can't install roccat-tools-konextd because roccat-tools-koneplus doesn't supply 'koneplus'.

bluezero4 commented on 2014-03-15 02:57

The package "roccat-tools-kone" satisfies the dependency for "kone" in "roccat-tools-koneplus", but "roccat-tools-koneplus" does not provide "koneplus" to satisfy the dependency in "roccat-tools-konextd". The Kone Pure packages depend on the Kone XTD package, so they can't be installed either. Additionally the Isku FX package doesn't seem to acknowledge the presence of the Iksu package either.

aaronfischer commented on 2014-03-05 20:22

- Removed the header files which are not needed any more
+ Add a install file for some post processing stuff. See roccat-tools.install or the scripts/post_install script in the source for more information.

Thanks to Stefan (erazor_de) -- the original author of this code -- for this suggestions!

von commented on 2014-02-27 23:25

roccat-tools-1.4.1.tar.bz2
Released on 2014-02-27

AsavarTzeth commented on 2014-02-14 17:54

@FlutterRage: Thank you. This did occur to me just before I was going to check if anyone had answered. I kind of feel stupid now :P

aaronfischer commented on 2014-02-10 20:32

version bump.

FlutterRage commented on 2014-02-09 16:47

@AsavarTzeth: Are you using an AUR helper like packer or yaourte? Afaik they don't support split packages, so you have to download the pkgbuild and build it yourself.

AsavarTzeth commented on 2014-02-09 14:39

First issue: There is a new version, 1.4 now.

Second issue: The only package that installs on my system is roccat-tools-common.
How do I get the GUI, and the other userland tools?

aaronfischer commented on 2014-02-07 13:07

Thanks!