Package Base Details: roccat-tools

Git Clone URL: https://aur.archlinux.org/roccat-tools.git (read-only)
Keywords: gui hardware keyboard mouse settings
Submitter: russo79
Maintainer: aaronfischer
Last Packager: aaronfischer
Votes: 55
Popularity: 0.096930
First Submitted: 2012-03-05 16:53
Last Updated: 2019-08-24 19:39

Pinned Comments

aaronfischer commented on 2019-03-28 20:13

@Gonzo2028: See here: https://www.reddit.com/r/linux_gaming/comments/5js1l2/im_stefan_achatz_stopping_programming_linux/

Stunts commented on 2017-01-05 13:13

@gonzo2028:
There are 2 alternative ways:
1. @aaronfischer splits the package into 25 different ones and whenever there is an update he will have to update 25 individual packages; good for the useres, not so good for the maintainer.
2. @aaronfischer "merges" all the files from the split packages into a single package. This will result in installing binaries, udev rules and .desktop files for 25 devices for every user. Less work for the maintainer, not practical for the users.

As is it, the maintainer maintains one single "split-package" and users that use an AUR helper such as yaourt, can uninstall the packages they don't need. This way users get to keep only the files they need to support their own device and the maintainer does not have to modify and commit 25 packages every time there is an update.

Hope this helps clear it.

aaronfischer commented on 2015-11-22 13:21

@edward_81: Please read the previous comments here. I've talked to Stefan about this. Every version of roccat-tools need a specific version of libgaminggear to work correctly. There are two options here: Consistent/reliable package and a little bit of hasle on upgrades -- or easy upgrade process and the chance of a broken package with weird bugs everywhere. I've choosen the first option.

edward_81 commented on 2015-10-03 15:31

Is possible to change the dependency line for libgaminggear from:
libgaminggear=0.11.1
to:
libgaminggear>=0.11.1
Because every time i try to upgrade the system with yaourt/aur, it complain that roccat-tool-common need that exactly version of libgaminggear.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

lord_rel commented on 2016-04-19 12:28

i get
- Checking for module 'gudev-1.0'
-- No package 'gudev-1.0' found
CMake Error at cmake_modules/FindGUDEV.cmake:28 (MESSAGE):
Could not find GUDEV
Call Stack (most recent call first):
CMakeLists.txt:81 (FIND_PACKAGE)

pacman -Qs gudev
local/libgudev 230-1

LeonardK commented on 2016-04-17 10:37

@Salamandar
Reas the comments. They are even partly pinned. Is there a "comment-blocker" around which blocks the display of comments except the own ones?!

Salamandar commented on 2016-04-17 09:54

Why is there dependencies roccat-tools-koneplus > roccat-tools-konextd > roccat-tools-konepure ?
I just wanna install konepure… And this package is not well written, it compiles and installs every package.

GosuSan commented on 2016-03-07 19:20

@aaronfischer: Jep, I do use yaourt, didn't know that is any different to building it myself. Did find the issue, thanks :)

aaronfischer commented on 2016-03-07 18:55

@GosuSan: Do you use any package helper like yaourt? roccat-tools-common does not depend on the other packages. roccat-tools-koneplus only depends on roccat-tools-common.

GosuSan commented on 2016-03-07 18:46

Is there a way to install only the packages I need?
Whenever I install roccat-tools-common OR roccat-tools-koneplus / roccat-tools-isku all of the 21 packages is installed. Why is that? I really don't want all this stuff on my system I never use because I don't have the hardware.

GH0S1_R33P0R commented on 2015-12-29 22:03

@fettouhi run
$sudo usermod -a -G roccat $USER

I had to re-do that after installing apparently.

GH0S1_R33P0R commented on 2015-12-27 20:51

@aaronfischer Just did

aaronfischer commented on 2015-12-17 09:31

@fettouhi, @GH0S1_R33P0R: Can you open a ticket upstream about this problem? http://sourceforge.net/p/roccat/bugs/

GH0S1_R33P0R commented on 2015-12-17 01:17

@fettouhi Started getting the seg fault as well. That only happened after I updated.