Package Base Details: roccat-tools

Git Clone URL: https://aur.archlinux.org/roccat-tools.git (read-only)
Keywords: gui hardware keyboard mouse settings
Submitter: russo79
Maintainer: aaronfischer
Last Packager: aaronfischer
Votes: 55
Popularity: 0.099576
First Submitted: 2012-03-05 16:53
Last Updated: 2019-05-16 20:50

Pinned Comments

aaronfischer commented on 2019-03-28 20:13

@Gonzo2028: See here: https://www.reddit.com/r/linux_gaming/comments/5js1l2/im_stefan_achatz_stopping_programming_linux/

Stunts commented on 2017-01-05 13:13

@gonzo2028:
There are 2 alternative ways:
1. @aaronfischer splits the package into 25 different ones and whenever there is an update he will have to update 25 individual packages; good for the useres, not so good for the maintainer.
2. @aaronfischer "merges" all the files from the split packages into a single package. This will result in installing binaries, udev rules and .desktop files for 25 devices for every user. Less work for the maintainer, not practical for the users.

As is it, the maintainer maintains one single "split-package" and users that use an AUR helper such as yaourt, can uninstall the packages they don't need. This way users get to keep only the files they need to support their own device and the maintainer does not have to modify and commit 25 packages every time there is an update.

Hope this helps clear it.

aaronfischer commented on 2015-11-22 13:21

@edward_81: Please read the previous comments here. I've talked to Stefan about this. Every version of roccat-tools need a specific version of libgaminggear to work correctly. There are two options here: Consistent/reliable package and a little bit of hasle on upgrades -- or easy upgrade process and the chance of a broken package with weird bugs everywhere. I've choosen the first option.

edward_81 commented on 2015-10-03 15:31

Is possible to change the dependency line for libgaminggear from:
libgaminggear=0.11.1
to:
libgaminggear>=0.11.1
Because every time i try to upgrade the system with yaourt/aur, it complain that roccat-tool-common need that exactly version of libgaminggear.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

fettouhi commented on 2015-12-10 20:57

Anybody else getting segmentation fault after the gcc ABI update? Tried rebuilding the packages but still I get segmentation faults

aaronfischer commented on 2015-11-22 13:21

@edward_81: Please read the previous comments here. I've talked to Stefan about this. Every version of roccat-tools need a specific version of libgaminggear to work correctly. There are two options here: Consistent/reliable package and a little bit of hasle on upgrades -- or easy upgrade process and the chance of a broken package with weird bugs everywhere. I've choosen the first option.

aaronfischer commented on 2015-11-22 13:16

@BRAXS69: Thanks! I've fixed the libgaminggear package and added you to the list of contributors.

@Freso: That is not a problem of the package itself, It is a problem of the design/structure of the roccat-tools source code. I can't do much improvement on this, sorry :(

BRAXS69 commented on 2015-11-17 09:48

For hose having trouble building with the error:

Could not find a package configuration file provided by "GAMINGGEAR0"

This is caused by the "libgaminggear" package dependency, it has the INSTALL_CMAKE_MODULESDIR option using a directory of the old cmake 3.3 the current for arch is 3.4.

Simply edit the PKGBUILD of libgaminggear removing the line:

-DINSTALL_CMAKE_MODULESDIR="/usr/share/cmake-3.3/Modules"
( don't forget to remove the "\" at the end of the previous line )

build() {
cd "${srcdir}/${pkgname}-${pkgver}"
cmake \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DINSTALL_LIBDIR="/usr/lib"
make
}

Freso commented on 2015-11-14 10:42

Why is roccat-tools-konextdoptical depending on roccat-tools-konepuremilitary, which in turn depends on roccat-tools-konepure, which depends roccat-tools-konextd, which depends on roccat-tools-koneplus? It seems like there's some room for optimisation here, so you won't have to install compatibility for 5 different mice when you only need one.

edward_81 commented on 2015-10-03 15:31

Is possible to change the dependency line for libgaminggear from:
libgaminggear=0.11.1
to:
libgaminggear>=0.11.1
Because every time i try to upgrade the system with yaourt/aur, it complain that roccat-tool-common need that exactly version of libgaminggear.

aaronfischer commented on 2015-08-28 18:43

Thanks a lot! I don't increment the pkgrel because the package works with and without the patch and there is no need to rebuild the package.
Everyone who make this package better in some way is a contributor in my sense of view :)

txus commented on 2015-08-28 16:09

No problem, but being too lazy to even write a patch I don't think I deserve to be called "Contributor" :P. Thanks anyway!

Aaand another: I just built everything without the gudev patch. I think it's not needed since whatever version was released in/after June, according to the ticket in sourceforge. Here's the PKGBUILD: http://pastebin.com/hz8sbfeS

aaronfischer commented on 2015-08-27 21:29

Thanks Jesus for the hint! I've fixed the package and addes you to the list of contributors.

txus commented on 2015-08-26 19:42

There are errors in the PKGBUILD concerning the installation of udev rules, where the savu rules are copied into both into the kone pure military and kone xtd optical packages.