Package Base Details: roccat-tools

Git Clone URL: https://aur.archlinux.org/roccat-tools.git (read-only)
Keywords: gui hardware keyboard mouse settings
Submitter: russo79
Maintainer: aaronfischer
Last Packager: aaronfischer
Votes: 55
Popularity: 0.330174
First Submitted: 2012-03-05 16:53
Last Updated: 2019-05-16 20:50

Pinned Comments

aaronfischer commented on 2019-03-28 20:13

@Gonzo2028: See here: https://www.reddit.com/r/linux_gaming/comments/5js1l2/im_stefan_achatz_stopping_programming_linux/

Stunts commented on 2017-01-05 13:13

@gonzo2028:
There are 2 alternative ways:
1. @aaronfischer splits the package into 25 different ones and whenever there is an update he will have to update 25 individual packages; good for the useres, not so good for the maintainer.
2. @aaronfischer "merges" all the files from the split packages into a single package. This will result in installing binaries, udev rules and .desktop files for 25 devices for every user. Less work for the maintainer, not practical for the users.

As is it, the maintainer maintains one single "split-package" and users that use an AUR helper such as yaourt, can uninstall the packages they don't need. This way users get to keep only the files they need to support their own device and the maintainer does not have to modify and commit 25 packages every time there is an update.

Hope this helps clear it.

aaronfischer commented on 2015-11-22 13:21

@edward_81: Please read the previous comments here. I've talked to Stefan about this. Every version of roccat-tools need a specific version of libgaminggear to work correctly. There are two options here: Consistent/reliable package and a little bit of hasle on upgrades -- or easy upgrade process and the chance of a broken package with weird bugs everywhere. I've choosen the first option.

edward_81 commented on 2015-10-03 15:31

Is possible to change the dependency line for libgaminggear from:
libgaminggear=0.11.1
to:
libgaminggear>=0.11.1
Because every time i try to upgrade the system with yaourt/aur, it complain that roccat-tool-common need that exactly version of libgaminggear.

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9 10 11 12 13 14 ... Next › Last »

Ghul commented on 2015-02-11 23:39

Don't know what happened on 3.0.0 release... Sound for eventhandler is far too high, even at minimal volume.

maxyme commented on 2015-02-11 16:08

stqn: Yeah, If you use yaourt, I just add everything except roccat-tools-common to the ignorelist.

Anonymous comment on 2015-02-11 15:55

I don’t understand this package, it creates a roccat-tools-savu package even though there is a separate roccat-tools-savu package on the AUR, and also this page is named roccat-tools-common but the tarball is named roccat-tools…

aaronfischer commented on 2015-02-10 09:57

bump to version 3.0.0
The ryos package is renamed to ryosmk!
And keep in mind that you need to update libgaminggear (0.6.0) before installing version 3.0.0. There is no backward compatibility.

von commented on 2015-01-27 16:32

2.4.0 is out

Ghul commented on 2015-01-24 10:08

Thnx to mattlyons I found my issue. My FindGAMINGGEAR0.cmake was not in /usr/share/cmake/Modules but in /usr/share/cmake-3.0/Modules, but I had to copy it in /usr/share/cmake-3.1/Modules to make it work.

maxyme commented on 2015-01-23 06:15

I fixed it, FindGAMINGGEAR0.cmake is located in /usr/share/cmake/Modules, when the script is looking for it in /usr/share/cmake-3.1/Modules. Easy fix, copy it into the folder.

aaronfischer commented on 2015-01-22 21:47

Can't reproduce this. Can you provide a fix for this?

Ghul commented on 2015-01-21 08:39

same issue here as mattlyons

maxyme commented on 2015-01-16 13:00

@aaronfischer: Reinstalling didn't change anything.