Package Base Details: roccat-tools

Git Clone URL: https://aur.archlinux.org/roccat-tools.git (read-only)
Keywords: gui hardware keyboard mouse settings
Submitter: russo79
Maintainer: aaronfischer
Last Packager: aaronfischer
Votes: 55
Popularity: 0.192651
First Submitted: 2012-03-05 16:53
Last Updated: 2019-05-16 20:50

Pinned Comments

aaronfischer commented on 2019-03-28 20:13

@Gonzo2028: See here: https://www.reddit.com/r/linux_gaming/comments/5js1l2/im_stefan_achatz_stopping_programming_linux/

Stunts commented on 2017-01-05 13:13

@gonzo2028:
There are 2 alternative ways:
1. @aaronfischer splits the package into 25 different ones and whenever there is an update he will have to update 25 individual packages; good for the useres, not so good for the maintainer.
2. @aaronfischer "merges" all the files from the split packages into a single package. This will result in installing binaries, udev rules and .desktop files for 25 devices for every user. Less work for the maintainer, not practical for the users.

As is it, the maintainer maintains one single "split-package" and users that use an AUR helper such as yaourt, can uninstall the packages they don't need. This way users get to keep only the files they need to support their own device and the maintainer does not have to modify and commit 25 packages every time there is an update.

Hope this helps clear it.

aaronfischer commented on 2015-11-22 13:21

@edward_81: Please read the previous comments here. I've talked to Stefan about this. Every version of roccat-tools need a specific version of libgaminggear to work correctly. There are two options here: Consistent/reliable package and a little bit of hasle on upgrades -- or easy upgrade process and the chance of a broken package with weird bugs everywhere. I've choosen the first option.

edward_81 commented on 2015-10-03 15:31

Is possible to change the dependency line for libgaminggear from:
libgaminggear=0.11.1
to:
libgaminggear>=0.11.1
Because every time i try to upgrade the system with yaourt/aur, it complain that roccat-tool-common need that exactly version of libgaminggear.

Latest Comments

« First ‹ Previous ... 5 6 7 8 9 10 11 12 13 14 15 ... Next › Last »

aaronfischer commented on 2015-01-16 09:26

@mattlyons: You need to (re?)install libgaminggear 0.5.0

maxyme commented on 2015-01-15 20:42

I'm getting a failure building:
CMake Error at CMakeLists.txt:67 (FIND_PACKAGE):
By not providing "FindGAMINGGEAR0.cmake" in CMAKE_MODULE_PATH this project
has asked CMake to find a package configuration file provided by
"GAMINGGEAR0", but CMake did not find one.

Could not find a package configuration file provided by "GAMINGGEAR0"
(requested version 0.5.0) with any of the following names:

GAMINGGEAR0Config.cmake
gaminggear0-config.cmake

Add the installation prefix of "GAMINGGEAR0" to CMAKE_PREFIX_PATH or set
"GAMINGGEAR0_DIR" to a directory containing one of the above files. If
"GAMINGGEAR0" provides a separate development package or SDK, be sure it
has been installed.

dccafe commented on 2014-12-01 10:04

Hi,

Shouldn't roccateventhandler be started by systemd? The desktop file in /etc/xdg/autostart/ is started for local users only, and as far as I know, local users don't have access to /dev/input/. I can only use roccat macros when I run "sudo roccateventhandler".

von commented on 2014-10-03 18:40

@aaronfischer, thanks for the info and the update.

aaronfischer commented on 2014-09-30 20:22

@Von: I subscribed to the sf.net/roccat-tools updates, and get the mail, but did not had the time to check the Changelog, figure out the libgaminggear version, prepare the PKGBUILD, test it and upload it. Sorry for the delay. We are now running version 2.2.0 with libgaminggear 0.5.0. Please note that kmod-roccat is no longer needed for the most devices. You can remove this package now if you not own a kone device. IF you own a kone device, upgrade to 1.0.0.

von commented on 2014-09-29 14:12

Err, oh wow. I've just noticed I've already asked this same question couple of months before lol. Thanks for the answer anyway @erazor.

erazor commented on 2014-09-27 06:55

That libgaminggear specifity is caused by me. At the moment libgaminggears interface is constantly changing, hence it's major version 0 and the one-version-of-libgaminggear-for-one-version-of-roccat-tools dependency. I'm hoping to end this inconvenience in the near future.

von commented on 2014-09-25 20:39

also any specific reason to depend on specific version of libgaminggear? Why not use libgaminggear>=0.4.0 instead of libgaminggear=0.4.0 ? Updating to newer libgaminggear in your case requires either removal of roccat-tools or breaking deps.

von commented on 2014-09-25 20:28

You can subscribe to updates on sourceforge you know. And get email with each new release on the projects you follow. A very useful feature for a maintainer.

AnAkkk commented on 2014-07-11 20:21

I've removed my comments because I found out the issue: my user was no longer in the group "roccat".