Package Base Details: rust-git

Git Clone URL: https://aur.archlinux.org/rust-git.git (read-only)
Keywords: mozilla rust
Submitter: mrshpot
Maintainer: spider-mario (ishitatsuyuki)
Last Packager: ishitatsuyuki
Votes: 25
Popularity: 0.000000
First Submitted: 2012-01-21 11:30
Last Updated: 2018-02-11 11:49

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 Next › Last »

spider-mario commented on 2014-10-22 06:33

Thanks a lot for your feedback, $SRCDEST indeed appears to be the right variable to use.

abandonedaccount commented on 2014-10-22 05:16

@spider-mario very nice, using the info you provided, replacing $startdir with $SRCDEST works as intended; maybe worth noting what's my env:
PKGDEST=/tmp/packages
SRCDEST=/tmp/sources
SRCPKGDEST=/tmp/srcpackages
BUILDDIR=/tmp/makepkg
and $startdir is /home/emacs/build/rust-git
Thanks.

spider-mario commented on 2014-10-20 18:20

@Svenstaro: I can’t reproduce the issue. What are your MAKEFLAGS? Perhaps we should go back to `options=(!makeflags)`.

@emanueLczirai: weird, it works for me. :/ The way the script works is that for each line in .gitmodules that looks like “$url = (...)/$submodule[.git]”, if $startdir/$submodule/ is an existing directory then the line is replaced with “$url = $startdir/$submodule/”.

abandonedaccount commented on 2014-10-20 11:25

The perl script in prepare() doesn't seem to modify .gitmodules anymore and they are downloaded/cloned by the ./configure instead of using the repos that pacman already downloaded/cloned. I've no idea how to fix it currently because I don't know perl. Someone please look into it? Thanks.

Svenstaro commented on 2014-10-17 23:05

For some reason, I end up with an empty package after making this. spider-mario, please look into it.

Binero commented on 2014-07-09 09:50

This package seems to 'make clean' automatically. Rather annoying due to the time it consumes compiling.

gsnedders commented on 2014-06-10 13:29

Bah, I must be blind! I had a quick look at options and managed to glaze over the "!" and got slightly confused but moved on. But yes — parallel builds appear to work now.

heinrich5991 commented on 2014-06-09 22:47

Maybe you could make a blacklist isntead of a whitelist. Also note that it currently misses all files directly in the doc directory (not the subfolders).

spider-mario commented on 2014-06-09 21:58

The goal was to avoid copying useless .aux, .log and .out files, but indeed, missing useful files is worse.

heinrich5991 commented on 2014-06-09 20:36

The docs are not properly copied, it misses the JS files at least. Why does it make a selection based on file extension?