Package Base Details: samsung-unified-driver

Git Clone URL: https://aur.archlinux.org/samsung-unified-driver.git (read-only, click to copy)
Submitter: ptb
Maintainer: christoph.gysin
Last Packager: christoph.gysin
Votes: 209
Popularity: 0.94
First Submitted: 2010-12-06 00:01
Last Updated: 2019-10-21 12:26

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

Amphitryon commented on 2019-04-15 17:11

Given that the CUPS bug has been closed as a driver issue what is the way forward now? We can obviously hope that Samsung update the driver but in case that takes a long time does anyone understand enough about what michaelrsweet was saying to be able to patch the Samsung driver to work with CUPS 2.11 in the meantime?

deKay commented on 2019-04-15 15:03

Cant install it because a couple files already exist. samsung-unified-driver-printer: /usr/lib/cups/backend/smfpnetdiscovery existiert bereits im Dateisystem

samsung-unified-driver-printer: /usr/lib/cups/filter/pstosecps existiert bereits im Dateisystem

samsung-unified-driver-printer: /usr/lib/cups/filter/rastertospl existiert bereits im Dateisystem

samsung-unified-driver-scanner: /opt/samsung/scanner/share/oem.conf existiert bereits im Dateisystem

samsung-unified-driver-scanner: /usr/lib/sane/libsane-smfp.so existiert bereits im Dateisystem

samsung-unified-driver-scanner: /usr/lib/sane/libsane-smfp.so.1 existiert bereits im Dateisystem

samsung-unified-driver-scanner: /usr/lib/sane/libsane-smfp.so.1.0.1 existiert bereits im Dateisystem

samsung-unified-driver-scanner: /usr/share/locale/fr/LC_MESSAGES/sane-smfp.mo existiert bereits im Dateisystem

ingo66 commented on 2019-04-11 19:23

@aneiser - Puh ... thank you :)

aneiser commented on 2019-04-11 19:20

@ingo66 I finished bisecting it and found the following commit to be the culprit:

https://github.com/apple/cups/commit/558bba72feccba755135e140c350bb34ec20986c

Reported an issue here: https://github.com/apple/cups/issues/5562 Feel free to add more information into the issue.

My printer is a Samsung CLX-3185.

ingo66 commented on 2019-04-11 18:44

Hello,

Ok, I have tried the following:

$ git clone  <https://github.com/apple/cups.git>
$ cd cups
$ git bisect start
$ git bisect good v2.2.10
$ git bisect bad v2.2.11

with the result:

binäre Suche: danach noch 16 Commits zum Testen übrig (ungefähr 4 Schritte)
[019198b76b1164cfad27cd4543acb08e7db01f9e] Missing printer-uri when enabling printer (mirror fix from master).

Was that the idea up to here?

In the INSTALL.md I read about ./configure; make; make check. I have never created a package for arch linux before. Is this even necessary for the further steps?

christoph.gysin commented on 2019-04-10 20:13

@ingo66 You would need to use git bisect and build cups after every step, and after 5-6 steps you would know exactly which commit caused it.

ingo66 commented on 2019-04-10 19:00

Hello,

I looked at all commits between 13.01.2019 (version 2.2.10) and 24.03.2019 (version 2.2.11), but unfortunately I don't have the necessary knowledge to be able to say which one led to the current situation.

Sorry.

christoph.gysin commented on 2019-04-10 10:40

@liOnux @ingo66

This might be a regression in cups. Could you bisect the changes since v2.2.10 to see which commit caused it?

https://github.com/apple/cups/compare/v2.2.10...v2.2.11

We could then report it upstream, and ask the maintainer of the cups package to revert the commit for now.

ingo66 commented on 2019-04-09 18:55

Hello,

With the samsung-unified-driver 4.00.39-5 for my Samsung CLP-310 along with cups and libcups 2.2.11-1 I have a similar Error-Message by sending a print job.

After downgraded cups and libcups to 2.2.10-2 the printer prints as expected.

liOnux commented on 2019-03-29 16:35

Hi, Since I updated cups and libcups from 2.2.10-2 to 2.2.11-1,

my Samsung CLP-320 prints this :

SPL-C ERROR - Please use the proper driver
POSITION : 0x0 (0)
SYSTEM : src_5.47/xl_image
LINE : 629
VERSION : SPL-C 5.47 01-15-2010