Package Base Details: slim-git

Git Clone URL: https://aur.archlinux.org/slim-git.git (read-only)
Submitter: Cinelli
Maintainer: bidulock
Last Packager: bidulock
Votes: 65
Popularity: 0.000000
First Submitted: 2012-12-19 04:30
Last Updated: 2015-12-15 18:15

Packages (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

WorMzy commented on 2013-01-09 22:14

The problem with that is that you need a /etc/slim.conf for slimlock to read to get it's configuration, and having the slimlock package provide it means that it'd conflict with the slim package.

I've had a think while I've been away, and I've decided that it's best to install an example slim.conf and a basic theme to /usr/share, and then prompt the user to either install slim to have everything work out of the box, or copy the example slim.conf to /etc and configure it themselves. There's loads of slim themes in the AUR that the user can use if they don't like the default, and it makes it more obvious that just because it's 'slimlock', doesn't mean it can't be used with other login managers.

dannyn commented on 2013-01-09 03:06

How about the installer installing a theme there by default if there isnt anything there yet?

WorMzy commented on 2013-01-08 00:38

I disagree. You can create /etc/slim.conf and a theme manually and and it'll work whether slim is installed or not. The slim binary is never used, and there's no shared libraries in the slim package that slimlock needs.

I might add it to the optdepends, or include an .install explaining how to get it to work without installing slim though.

FreeAsInGimme commented on 2013-01-07 23:20

Like 3V0LU710N said a while back, slim needs to be added as a dependency. Without it, running slim lock yields "Failed to open default theme file /usr/share/slim/themes/default/slim.theme."

WorMzy commented on 2013-01-02 11:08

Cheers for the heads up, I've updated the PKGBUILD.

dannyn commented on 2013-01-02 03:41

I've renamed the repo to https://github.com/dannyn/slimlock. Got a couple of more fixes coming soon too.

WorMzy commented on 2012-09-11 09:48

For those trying to build this:

- Add 'libxrandr' to the depends array
- Change _gitroot to "git://github.com/joelburget/slimlock.git"

I've emailed Guff, to make sure he's aware that the package is out of date, so hopefully these changes will be made in the PKGBUILD soon.

Anonymous comment on 2012-08-05 10:09

The package is mentioned in the Slim set-up guide here: https://wiki.archlinux.org/index.php/SLIM#Changing_the_cursor

I could not find it in the repo and found my way here.

The wiki should be updated.

Side note: registering an account in this system does not verify the email address used. This should be changed to allow verification.

WorMzy commented on 2012-06-28 13:57

libxrandr needs to be added to the depends array.

3V0LU710N commented on 2012-05-27 22:54

Please add 'slim' to the depends array... =)