Package Base Details: spotifyd-bin

Git Clone URL: https://aur.archlinux.org/spotifyd-bin.git (read-only, click to copy)
Submitter: Varakh
Maintainer: Varakh
Last Packager: Varakh
Votes: 6
Popularity: 0.018486
First Submitted: 2017-03-26 11:46
Last Updated: 2020-02-10 10:17

Pinned Comments

Varakh commented on 2020-01-28 18:29

ARM added back to the PKGBUILD. Unfortunately upstream does not provide the 'full' package for armv6. Use this instead if it works for you.

Latest Comments

1 2 Next › Last »

tim_heap commented on 2020-02-10 09:14

The sha256sum for the armv6h package is incorrect. It is a copy of the sha256sum of the x86_64 and aarch64 package. The correct sha256sum is 8c8d46469901da1996031db1ea08cd51d3705006f5f67312572c2913ecf7597e

Varakh commented on 2020-01-28 18:29

ARM added back to the PKGBUILD. Unfortunately upstream does not provide the 'full' package for armv6. Use this instead if it works for you.

bjo commented on 2020-01-24 21:24

ARM builds are back.

Varakh commented on 2019-12-29 14:13

I'll add ARM once a new version has been released and the binaries are available.

bjo commented on 2019-12-28 18:46

I think the build of the arm binaries failed and they will be added back: https://github.com/Spotifyd/spotifyd/issues/425

Varakh commented on 2019-12-28 09:57

You're right, upstream doesn't provide any arm binaries anymore. I removed it from the supported list of archs, feel free to use the plain spotifyd package as WhyNotHugo mentioned.

bjo commented on 2019-12-28 02:38

Your pkgbuild does not work on armv7h any more, so arch = armv6h and arch = armv7h should be removed

WhyNotHugo commented on 2019-12-18 13:27

@mikes This is a binary package, and the binary file is built for the only architecture that ArchLinux supports. For ARM, you'll probably need to use spotifyd, the non-binary package.

mikes commented on 2019-12-18 13:24

Thanks for the package!

I just tested it on aarch64 and it does not work. I tested the command manually and I get:

cannot execute binary file: Exec format error

any idea?

EDIT:

I just downloaded the tar from github and it only has one binary. I thought that it would include binaries for different architectures. So this is the reason it cannot be executed cause it obviously isn't for aarch64!

NicoHood commented on 2018-06-12 15:15

Please add a conflict against spotifyd and provide spotifyd at the same time. Then users get a warning when one of those package is already installed.