Package Base Details: spyder-git

Git Clone URL: https://aur.archlinux.org/spyder-git.git (read-only)
Submitter: willemw
Maintainer: willemw
Last Packager: willemw
Votes: 21
Popularity: 1.632691
First Submitted: 2015-02-24 08:52
Last Updated: 2019-06-11 15:09

Packages (2)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

fabmazz commented on 2019-07-19 22:22

Now spyder 4 requires python-watchdog as a depedency. They just keep adding new ones....

Also, I think that building spyder for both python 2 and python 3 at the same time is confusing and not useful at all. I think it goes against the minimalist principle of Arch, and, given that Python 2 will soon reach EOL, is not useful at all.

If the packages could be split for different Python versions it would be great... otherwise I will continue to remove parts of the PKGBUILD each time xD

willemw commented on 2019-06-11 15:16

@fabmazz: Thanks. Added the already existing python-diff-match-patch package as dependency. There is no python2-diff-match-patch (because Python 2 is almost EOL?).

Note: Spyder3 complains about missing pyls (PYLS_REQVER = '>=0.19.0;<0.25'). The Arch version is 0.26.1-1.

fabmazz commented on 2019-06-11 14:38

Now spyder 4 requires the diff-match-patch library. Maybe add the AUR package "python-diff_match_patch" to the dependencies?

akspecs commented on 2019-02-22 21:21

@willemw:

Thanks! The workaround in this case is simple: via the dropdown menu tools > preferences in the general tab there's another dropdown that gives the option to choose the spyder2 icon theme. This prevents the issue from recurring for the time being until the incompatibility between qtawesome and pyqt5 5.12 is resolved.

willemw commented on 2019-02-22 13:06

@akspecs: Seems to be a known issue: https://github.com/spyder-ide/spyder/issues/8748

akspecs commented on 2019-02-22 08:11

@willemw:

After installing python-qtawesome-git I'm able to run the IDE, but buttons are glitching out with graphical artifacts as pictured here:

https://i.imgur.com/QBRNFNF.png

willemw commented on 2019-02-15 10:11

@akspecs:

I have added all the new dependencies to PKGBUILD, except for python2-qdarkstyle which is not available.

I am not seeing the "Invalid icon name" exception. Do you have python-qtawesome-git installed and is it up-to-date?

akspecs commented on 2019-02-15 06:56

I'm unable to run spyder3-git. Any help or advice would be greatly appreciated. I get the following error: https://pastebin.com/raw/SnzuEP37

edit: after installing 'python-atomicwrites', it became clear I also needed to have 'python-spyder-kernels-git' rather than just 'python-spyder-kernels'. Then I later learned that 'python-qdarkstyle' is also needed. But even with these extra dependencies installed, I'm still left with the following error: https://pastebin.com/raw/WHZ9f5Je

The last line of the error being: Exception: Invalid icon name "format-letter-case" in font "mdi"

willemw commented on 2018-09-27 18:14

@cerikson: Thanks. Updated to include all new dependencies.

cerikson commented on 2018-09-27 17:30

Just did a install on a fresh system and the dependency python-language-server was missing after install. Which caused spyder3 to crash on startup.