Package Base Details: spyder-git

Git Clone URL: (read-only)
Submitter: willemw
Maintainer: willemw
Last Packager: willemw
Votes: 20
Popularity: 0.730628
First Submitted: 2015-02-24 08:52
Last Updated: 2019-06-11 15:09

Packages (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

frankscasket commented on 2017-03-27 16:40

Thanks for this. In addition, I needed to install the package python-qtpy.

willemw commented on 2016-12-17 07:44

@LeftyAce: Have you tried building without any old build files present?

LeftyAce commented on 2016-12-17 05:57

I'm getting the following error during the build process, any ideas?

Running Sphinx v1.5
Traceback (most recent call last):
File "", line 306, in <module>
File "/usr/lib/python2.7/distutils/", line 151, in setup
File "/usr/lib/python2.7/distutils/", line 953, in run_commands
File "/usr/lib/python2.7/distutils/", line 972, in run_command
File "/usr/lib/python2.7/distutils/command/", line 127, in run
File "/usr/lib/python2.7/distutils/", line 326, in run_command
File "/usr/lib/python2.7/distutils/", line 972, in run_command
File "", line 176, in run
File "/usr/lib/python2.7/site-packages/sphinx/", line 180, in run
handle_exception(app, self, exc, sys.stderr)
UnboundLocalError: local variable 'app' referenced before assignment

willemw commented on 2016-08-31 16:41

@contrebasse: Thanks. Improved the pep8 patch.

contrebasse commented on 2016-08-31 12:24

Sed doesn't find this file spyder/spyderlib/utils/ to patch for pycodestyle instead of pep8.

willemw commented on 2016-08-10 06:16

This package depends on python2-pyqt5, which should pull in all the required qt5 dependencies (qt5-base).

spdrfall commented on 2016-08-10 01:03

I have to install qt5 group package (34 members) to get this to work. Should qt5 (or the exact packages required, that are not listed as deps) be added to dependencies?

contrebasse commented on 2016-06-17 23:01

@JohnRobson Downgrade qtpy, spyder is not yet compatible with qtpy master.

JohnRobson commented on 2016-06-17 18:40

check_qt() function in /usr/lib/python3.5/site-packages/spyderlib/

This function has this problem:

$ /usr/bin/python3.5 /usr/bin/spyder3
Traceback (most recent call last):
File "/usr/bin/spyder3", line 3, in <module>
File "/usr/lib/python3.5/site-packages/spyderlib/app/", line 118, in main
from import spyder
File "/usr/lib/python3.5/site-packages/spyderlib/app/", line 48, in <module>
File "/usr/lib/python3.5/site-packages/spyderlib/", line 46, in check_qt
% (package_name, required_ver, actual_ver))
File "/usr/lib/python3.5/site-packages/spyderlib/", line 25, in show_warning
raise RuntimeError(message)
RuntimeError: Please check Spyder installation requirements:
PyQt5 5.2+ is required (found v1.1.0.dev0).

Even after update: python-qtpy-git python2-qtpy-git

davidovitch commented on 2016-06-05 11:04

@willemw: I missed that pyqt5 has qt5-webengine as a make dep. Must have mixed something up, because you are right, I can run spyder(3)-git without qt5-webengine.