Package Base Details: spyder-git

Git Clone URL: https://aur.archlinux.org/spyder-git.git (read-only)
Submitter: willemw
Maintainer: willemw
Last Packager: willemw
Votes: 21
Popularity: 1.573325
First Submitted: 2015-02-24 08:52
Last Updated: 2019-07-22 06:37

Packages (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

JohnRobson commented on 2016-06-17 18:40

check_qt() function in /usr/lib/python3.5/site-packages/spyderlib/requirements.py

This function has this problem:

$ /usr/bin/python3.5 /usr/bin/spyder3
Traceback (most recent call last):
File "/usr/bin/spyder3", line 3, in <module>
start.main()
File "/usr/lib/python3.5/site-packages/spyderlib/app/start.py", line 118, in main
from spyderlib.app import spyder
File "/usr/lib/python3.5/site-packages/spyderlib/app/spyder.py", line 48, in <module>
requirements.check_qt()
File "/usr/lib/python3.5/site-packages/spyderlib/requirements.py", line 46, in check_qt
% (package_name, required_ver, actual_ver))
File "/usr/lib/python3.5/site-packages/spyderlib/requirements.py", line 25, in show_warning
raise RuntimeError(message)
RuntimeError: Please check Spyder installation requirements:
PyQt5 5.2+ is required (found v1.1.0.dev0).

Even after update: python-qtpy-git python2-qtpy-git

davidovitch commented on 2016-06-05 11:04

@willemw: I missed that pyqt5 has qt5-webengine as a make dep. Must have mixed something up, because you are right, I can run spyder(3)-git without qt5-webengine.

willemw commented on 2016-06-05 10:21

@davidovitch. What breaks? How to check this?
Is qt5-webengine really additional dependency of python-qtpy-git? I only see qt5-webengine as a make dependency of pyqt5. This means qt5-webengine is built into pyqt5?

davidovitch commented on 2016-06-05 09:30

Initially, spyder-git broke when python-pyqt5 was upgraded to 5.6.0. Now qt5-webengine is an additional dependency of python-qtpy-git. Requires the latest changes from both spyder and qtpy. See also https://github.com/spyder-ide/spyder/pull/3198.

willemw commented on 2016-04-25 06:39

The nbconvert error/warning for spyder (python 3 version) has been fixed.

flocke commented on 2016-04-21 10:34

I opened a bug report for community/jupyter to add entrypoints as dependency: https://bugs.archlinux.org/task/49036

For the time being you can install entrypoints manually as user to fix the warning: pip3 install --user entrypoints

willemw commented on 2016-04-18 16:20

Nbconvert for python 3 is in package community/jupyter, but seems broken (same error as https://trac.macports.org/ticket/51167):
>>> import nbconvert
Traceback (most recent call last):
...
ImportError: No module named 'entrypoints'

Nbconvert for python 2 seems to be missing (in the community repo).

contrebasse commented on 2016-04-18 15:02

It now needs the package nbconvert, but I didn't find it as a package for arch linux.

willemw commented on 2016-01-25 19:34

@flying-sheep: Thanks. Updated.

flying-sheep commented on 2016-01-25 13:19

hi, newest git master has pyqt5 as default.

please update the dependencies:

spyder-git:
-python2-pyqt4
+python2-pyqt5

spyder3-git:
-python-pyqt4
+python-pyqt5