Package Base Details: spyder-git

Git Clone URL: https://aur.archlinux.org/spyder-git.git (read-only)
Submitter: willemw
Maintainer: willemw
Last Packager: willemw
Votes: 20
Popularity: 0.746795
First Submitted: 2015-02-24 08:52
Last Updated: 2019-06-11 15:09

Packages (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

Anonymous comment on 2015-12-05 23:55

@willewm: Thank you for updating the PKGBUILD.

Will python-qtawesome be added to the AUR soon?

willemw commented on 2015-12-05 18:05

@Nabobalis: Thanks. Updated PKGBUILD.

Added new python-qtawesome/python2-qtawesome dependencies, which depend on new python-qtpy/python2-qtpy dependencies. See python-qtawesome-git and python-qtpy-git base packages.

Anonymous comment on 2015-12-05 16:27

I get this issue, trying to install this,
==> Starting prepare()...
sed: can't read spyderlib/utils/external/pickleshare.py: No such file or directory
==> ERROR: A failure occurred in prepare().

willemw commented on 2015-11-25 11:45

Spyder can run with qt5 instead of qt4:
# pacman -S --asdeps python-pyqt5
$ QT_API=pyqt5 spyder3
Go to menu Help --> About Spyder... : "Python 3.5.0 64bits, Qt 5.5.1, PyQt5 5.5.1 on Linux"

Viper_Scull commented on 2015-11-24 20:32

But you can't run it since the iPython compiled with this package is loading PyQt4 by default , and both modules (pyqt5 and pyqt4) can't be imported at the same time:

"the PyQt5.QtCore and PyQt4.QtCore modules both wrap the QObject class"

contrebasse commented on 2015-11-21 12:59

You can choose which qt version (pyqt4, pyqt5, pyside) you use in the preferences.

Viper_Scull commented on 2015-11-21 11:42

Could spyder3-git be compiled with pyqt5 instead of pyqt4?

willemw commented on 2015-08-25 14:39

@contrebasse: Thanks. Solved.

contrebasse commented on 2015-08-25 08:26

spyderlib/userconfig.py has been replaced by spyderlib/config/user.py.

willemw commented on 2015-07-09 08:26

@contrebasse: The issue could be something specific on your system.

Try to isolate the problem, if you want. Are the read-only files owned by root? Is /tmp/makepkg only used by yaourt? My yaourt temp files are in yaourt specific directory /tmp/yaourt-tmp-$USER. Did you change /etc/yaourtrc? Try running makepkg directly. Or try pacaur, which cleans up after a build (Default: cleandevel=true # clean up devel package).