Package Base Details: spyder-git

Git Clone URL: https://aur.archlinux.org/spyder-git.git (read-only)
Submitter: willemw
Maintainer: willemw
Last Packager: willemw
Votes: 21
Popularity: 0.504993
First Submitted: 2015-02-24 08:52
Last Updated: 2019-07-22 06:37

Packages (2)

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8 9 Next › Last »

willemw commented on 2013-11-14 07:54

@Nabobalis:
No problem.

Let's first wait for the spyder 2.3 install instructions, which should
make clear whether the people at spyder prefer 1 or 2 spyder instances
(for python 2 / 3) on linux. Otherwise, we can just ask them.

And then first follow those 'spyder supported' instructions, to update
the arch linux package files.

Then after that, if there is a real need for it, we can perhaps have
PKGBUILD build and install 2 spyder instances.

Anonymous comment on 2013-11-13 21:46

@willemw

All fair points. However, for me, I felt that having two spyder installs was easier for me at this time so I could develop Python 2 and 3 code at the same time.

I accept that in very few cases this is an ideal or even desired solution by any sane people.

willemw commented on 2013-11-13 14:55

@Nabobalis
Thanks. that's great, but why would you want Spyder 2.3, coming soon with official Python 2 and 3 support, to also run under Python 2?

I plan to switch over to running Spyder under Python 3, when officially supported.

Also, there are no official Python 3 build and installation instructions for Spyder, last time I looked, so better wait for that or at least wait for Spyder 2.3. Until then, I assume you will be able to develop in Python 2 and 3 with just a Spyder / Python 3 installation.

Anonymous comment on 2013-11-13 14:27

I made a hacky/terrible PKGBUILD that creates a python2 and python3 version of spyder. Since both versions now use separate config directories they can work side by side.

This is my first time touching a PKGBUILD, so I can not guarantee that it won't melt your PC.

Look here: http://pastebin.com/CWzVejuw

flying-sheep commented on 2013-10-15 14:17

well, if i want the python3 version installed without installing the python2 dependencies, i’ll have to edit the pkgbuild. i think this warrants a second package.

davidovitch commented on 2013-10-12 08:56

Embarrassed apologies...I am not used to using a touchpad and accidentally flagged the package out of date...which it isn't...

willemw commented on 2013-07-23 09:59

@rubenvb: Thanks. Makedepends updated. I plan on migrating the package to python3 when spyder 2.3 comes out and python 3 is officially supported. I know it already can run in python3 (see PKGBUILD file). Spyder 2.3 will then support development in both python 2 and 3. I don't see a real need to add or rename packages that will then start with 'python-' or 'python2-' in this case. (Also, if you have spyder 2.3 running in python3, then why have another package that installs spyder in python2?)

rubenvb commented on 2013-07-23 09:32

mercurial should be in makedepends, and this should be named "python2-spyder-hg" because it is possible to use the dev branch with python3.

willemw commented on 2013-06-29 06:01

Update: patch for pylint2; don' install spyder_win_post_install.py.

willemw commented on 2013-06-24 13:17

Updated package (pacman 4.1, python dependencies, ...).