Package Base Details: tomb-git

Git Clone URL: https://aur.archlinux.org/tomb-git.git (read-only)
Submitter: BoySka
Maintainer: TrialnError
Last Packager: TrialnError
Votes: 5
Popularity: 0.000571
First Submitted: 2011-07-04 18:58
Last Updated: 2016-04-30 21:00

Packages (2)

Latest Comments

TrialnError commented on 2015-12-30 18:40

No need to flag a package out of date, that is built from the latest master on every build invoke.
Users are responsible to update those manually

Edit: Unless there a changes that need to be applied

HalosGhost commented on 2014-01-29 00:30

test0, fixed. However, as I no longer use Tomb, I will orphan this so that someone who is more involved with it can keep it up to date.

All the best,

test0 commented on 2014-01-28 22:16

BoySka:

--- PKGBUILD.old 2013-06-26 23:08:50.000000000 +0400
+++ PKGBUILD.new 2014-01-29 02:15:22.163260588 +0400
@@ -30,7 +30,7 @@
}

build() {
- cd "${_name}/extras/kdf"
+ cd "${_name}/extras/kdf-keys"
make
}

@@ -38,6 +38,6 @@
install -Dm644 "_${_name}" "${pkgdir}/usr/share/zsh/site-functions/_${_name}"
cd "${_name}"
make DESTDIR="${pkgdir}" PREFIX=/usr install
- cd extras/kdf
+ cd extras/kdf-keys
make DESTDIR="${pkgdir}" PREFIX=/usr install
}

Sorry for unclear comment. That directory was renamed.

BoySka commented on 2014-01-27 18:15

test0: what do you mean? what should be replaced?

test0 commented on 2014-01-27 18:05

Please replace "kdf" with "kdf-keys".

HalosGhost commented on 2013-06-26 19:09

Updated for kdf support.

BoySka commented on 2013-06-22 08:35

HalosGhost: the choice is up to the packager; that is, you. I think that such a critical feature should be handled as part of the package itself. Note that, while it adds libgcrypt as dependency, actually cryptsetup already depends on it, so there's no need for libgcrypt to be added to dependencies.

It is in extras/kdf

HalosGhost commented on 2013-06-22 05:20

Boyska, in which directory? And should it be managed as if it were a split package?

BoySka commented on 2013-06-12 09:14

Hey, kdf support has finally come back (see https://github.com/dyne/Tomb/issues/94) so it can (and should) be included in the package.
a simple
DESTDIR=${pkgdir} PREFIX=/usr make
should be enough.

Anonymous comment on 2013-05-19 18:43

Thank you very much, you are doing a great job! :D

HalosGhost commented on 2013-05-18 23:16

Tested. Confirmed. Revised. Fixed. Thanks for the report.

Anonymous comment on 2013-05-18 23:03

hi, im getting a:
autoreconf: 'configure.ac' or 'configure.in' is required

so, i can't install it.

HalosGhost commented on 2013-04-16 16:46

Package updated for makepkg 4.1 syntax and to correct build errors. Added simple zsh completion.

HalosGhost commented on 2013-04-16 16:46

Package updated for makepkg 4.1 syntax and to correct build errors. Added simple zsh completion.

HalosGhost commented on 2013-04-16 10:43

This PKGBUILD now fails to build due to a lack of an m4 directory. It also still uses the old makepkg <4.1 syntax. Please update or orphan. I would be happy to take over maintenence.

BoySka commented on 2012-01-30 16:06

There is now a repo for this:
see https://wiki.archlinux.org/index.php/Tomb#Installation

[crypto]
Server=http://tomb.dyne.org/arch_repo/$arch

Anonymous comment on 2011-07-04 20:27

Really good job boyska!

BoySka commented on 2011-07-04 18:59

This PKGBUILD is customizable: if you want to test different repos, just change two variables