Package Base Details: vala-panel-appmenu-xfce-git

Git Clone URL: https://aur.archlinux.org/vala-panel-appmenu-xfce-git.git (read-only, click to copy)
Submitter: rilian
Maintainer: rilian
Last Packager: rilian
Votes: 37
Popularity: 0.63
First Submitted: 2015-04-01 21:00 (UTC)
Last Updated: 2024-02-27 21:15 (UTC)

Latest Comments

1 2 3 4 5 6 .. 23 Next › Last »

rilian commented on 2024-04-13 18:10 (UTC)

@andreymal

Should be fixed in https://gitlab.com/vala-panel-project/vala-panel/-/commit/295d89200fe579489e567ac0efbfbcda76c77072

Please, upgrade your vala-panel-git makedependency.

andreymal commented on 2024-04-13 15:52 (UTC)

Can't install:

error: failed to commit transaction (conflicting files)
vala-panel-appmenu-mate-git: /usr/share/applets/org.valapanel.appmenu.plugin exists in filesystem (owned by vala-panel-appmenu-common-git)

gschwarz commented on 2024-04-10 19:24 (UTC)

It's probably an effect of the overall build system (when run on an installation which does not yet have cmake installed) and no specific shortcoming of this particular package. Please disregard my comment. Apologies for potentially causing confusion.

rilian commented on 2024-04-10 08:22 (UTC)

Why you think so? It has nothing to do with CMake.

gschwarz commented on 2024-04-09 20:58 (UTC) (edited on 2024-04-09 21:04 (UTC) by gschwarz)

The AUR package seems to be missing a build-time dependency on cmake and pkgconf. Maybe this is an implicit dependency which holds for many packages and thus need not be specified with each package?

gschwarz commented on 2024-03-26 19:35 (UTC) (edited on 2024-03-26 22:10 (UTC) by gschwarz)

Thanks, I can confirm that with today's code changes /usr/lib/vala-panel/appmenu-registrar -r can be launched and no longer terminates. Unlike with previous releases, it now is necessary to explicitly (auto-) start the registrar. Previously it was started by the plugin (maybe the respective code now should be removed from the plugin's code if it has not happened yet? Or fix it to have it automatically started again?)

rilian commented on 2024-03-26 15:14 (UTC)

bus thing should fixed now in latest registrar. You can try again, and it should not terminated after 10 seconds if referenced.

gschwarz commented on 2024-03-25 20:52 (UTC)

When registrar is already running, I get an error message when I try to start a second instance (not surprising). When it is not running and I start /usr/lib/vala-panel/appmenu-registrar (either with --reference or without) it terminates after about 8 to 10 seconds. Exit code to the shell is 0. I am not sure whether or not this is normal behaviour when launching the registrar from the shell nor how I could further investigate the reason for that behaviour.

rilian commented on 2024-03-25 15:24 (UTC)

You can, just run /usr/lib/vala-panel/appmenu-registrar. You can add it to autostart, or just use it with console. It actually has commandline options. You need to use --reference option.

gschwarz commented on 2024-03-24 15:49 (UTC)

I'm confused now. I do not explicitly start the registrar binary. From what I understand it is started through /usr/lib/xfce4/panel/plugins/libappmenu-xfce.so How should I add that command line option?