Package Base Details: vmware-horizon-client

Git Clone URL: https://aur.archlinux.org/vmware-horizon-client.git (read-only, click to copy)
Submitter: eworm
Maintainer: eworm
Last Packager: eworm
Votes: 40
Popularity: 0.60
First Submitted: 2015-01-08 15:17
Last Updated: 2021-07-21 13:50

Latest Comments

1 2 3 4 5 6 ... Next › Last »

coreyberla commented on 2021-07-23 15:34

Have you considering using the tarball version (instead of the installer bundle). It simplifies the PKGBUILD a lot and reduces the effort for someone to verify that it's not malicious. I ended up building my own just for the client, let me know if you'd like help finishing the rest.


source=("https://download3.vmware.com/software/view/viewclients/CART22FQ2/VMware-Horizon-Client-Linux-${pkgver}-${build}.tar.gz")
sha256sums=(368d0b08c1d5be109ab70f692fe9809377f7cf7c20a46bbf72eedf73e59f1035)

prepare() {
    cd "${srcdir}/VMware-Horizon-Client-Linux-${pkgver}-${build}/x64/"
    tar xzvf VMware-Horizon-Client-${pkgver}-${build}.x64.tar.gz
    tar xzvf VMware-Horizon-PCoIP-${pkgver}-${build}.x64.tar.gz
}

package() {
    mkdir -p "${pkgdir}/usr/share/"
    cd "${srcdir}/VMware-Horizon-Client-Linux-${pkgver}-${build}/x64/VMware-Horizon-Client-${pkgver}-${build}.x64"
    cp -a bin "${pkgdir}/usr/"
    cp -a lib "${pkgdir}/usr/"
    cp -a doc "${pkgdir}/usr/share/"
    cp -a share/locale "$pkgdir/usr/share/"
    cd "${srcdir}/VMware-Horizon-Client-Linux-${pkgver}-${build}/x64/VMware-Horizon-PCoIP-${pkgver}-${build}.x64"
    cp -a lib "${pkgdir}/usr/"
}

jskier commented on 2021-07-21 14:13

@eworm, sorry my mistake, looks like it was the cache, thank you!

eworm commented on 2021-07-21 13:45

Works for me... Possibly you have an old vmware-bundle.eclass file in your source cache?

jskier commented on 2021-07-21 13:28

Fix file integrity verification please. vmware-bundle.eclass ... FAILED

h2ash commented on 2021-02-26 14:27

@starfall07g, you must go to Preferences and choose "Do not verify server identity certificates"

warlord commented on 2021-01-18 12:16

I'm relatively new to arch and ran into an issue installing this. It was just that the vmware-keymaps was required to be installed first. I know it's listed in the dependencies above, but it was easily missed by me.

Once keymaps was installed it works just great.

Many thanks.

eworm commented on 2020-12-31 20:16

I guess you have an old file in your cache. Remove that and try again.

galeot commented on 2020-12-31 15:24

Can't build due to sha256sum fail on vmware-bundle.eclass

quite strange, as key in PKGBUILD seems to be correct

eworm commented on 2020-12-27 21:51

Updated url, please pull and retry.

Compassion commented on 2020-12-27 04:06

The dependency for https://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/eclass/vmware-bundle.eclass no longer exists.